Bug 738735 - repoclosure failure for 16-Beta.RC1 DVD
repoclosure failure for 16-Beta.RC1 DVD
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: opencv (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On: 737774
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-15 13:17 EDT by Andre Robatino
Modified: 2011-09-24 02:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-24 02:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-09-15 13:17:31 EDT
Description of problem:
16 Beta RC1 i386 DVD:

package: kipi-plugins-2.0.0-3.fc16.i686 from myrepo
  unresolved deps: 
     libopencv_imgproc.so.2.2
     libopencv_calib3d.so.2.2
     libopencv_objdetect.so.2.2
     libopencv_video.so.2.2
     libopencv_highgui.so.2.2
     libopencv_flann.so.2.2
     libopencv_contrib.so.2.2
     libopencv_legacy.so.2.2
     libopencv_ml.so.2.2
     libopencv_features2d.so.2.2
     libopencv_core.so.2.2
     libopencv_gpu.so.2.2
package: libkface-2.0.0-3.fc16.i686 from myrepo
  unresolved deps: 
     libopencv_features2d.so.2.2
     libopencv_video.so.2.2
     libopencv_core.so.2.2
     libopencv_imgproc.so.2.2
     libopencv_flann.so.2.2
     libopencv_highgui.so.2.2
     libopencv_contrib.so.2.2
     libopencv_legacy.so.2.2
     libopencv_ml.so.2.2
     libopencv_gpu.so.2.2
     libopencv_calib3d.so.2.2
     libopencv_objdetect.so.2.2

16 Beta RC1 x86_64 DVD:

package: kipi-plugins-2.0.0-3.fc16.x86_64 from myrepo
  unresolved deps: 
     libopencv_video.so.2.2()(64bit)
     libopencv_calib3d.so.2.2()(64bit)
     libopencv_flann.so.2.2()(64bit)
     libopencv_highgui.so.2.2()(64bit)
     libopencv_legacy.so.2.2()(64bit)
     libopencv_gpu.so.2.2()(64bit)
     libopencv_core.so.2.2()(64bit)
     libopencv_features2d.so.2.2()(64bit)
     libopencv_imgproc.so.2.2()(64bit)
     libopencv_contrib.so.2.2()(64bit)
     libopencv_objdetect.so.2.2()(64bit)
     libopencv_ml.so.2.2()(64bit)
package: libkface-2.0.0-3.fc16.x86_64 from myrepo
  unresolved deps: 
     libopencv_contrib.so.2.2()(64bit)
     libopencv_objdetect.so.2.2()(64bit)
     libopencv_ml.so.2.2()(64bit)
     libopencv_video.so.2.2()(64bit)
     libopencv_gpu.so.2.2()(64bit)
     libopencv_core.so.2.2()(64bit)
     libopencv_flann.so.2.2()(64bit)
     libopencv_highgui.so.2.2()(64bit)
     libopencv_legacy.so.2.2()(64bit)
     libopencv_features2d.so.2.2()(64bit)
     libopencv_imgproc.so.2.2()(64bit)
     libopencv_calib3d.so.2.2()(64bit)

Version-Release number of selected component (if applicable):
16 Beta RC1 DVD (both i386 and x86_64)
Comment 1 Adam Williamson 2011-09-15 15:32:57 EDT
+1 blocker, obviously, per the Alpha criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install".
Comment 2 Adam Williamson 2011-09-15 15:40:37 EDT
It looks like these were missed from:

https://admin.fedoraproject.org/updates/FEDORA-2011-12320

there's something strange about that update, too - on the Bodhi search it shows up as "php-facedetect-1.0.1-4.fc16, gstreamer-plugins-bad-free-0.10.22-2.fc16.1, opencv-2.3.1-1.fc16, frei0r-plugins-1.3-3.fc16, player-3.0.2-13.fc16" , but when you click on it, the list of included packages is just opencv and frei0r-plugins . I guess the other packages went through as part of another update or something.

kipi-plugins and libkface are both now sub-packages of digikam. There was a rebuild of 2.0.0 for opencv: http://koji.fedoraproject.org/koji/buildinfo?buildID=259783

and there have been two version bumps since then: http://koji.fedoraproject.org/koji/buildinfo?buildID=262936 , http://koji.fedoraproject.org/koji/buildinfo?buildID=263621 .

the rebuild was submitted as an update and submitted for stable but didn't quite make it ahead of freeze:

https://admin.fedoraproject.org/updates/digikam-2.0.0-4.fc16

easiest thing to do would just be to pull that in for RC2.
Comment 3 Nicolas Chauvet (kwizart) 2011-09-15 15:54:56 EDT
Others updates from the ticket are obviously missing from the dist-f16 tag.
Theses must be tagged as dist-f16 also.
I didn't expected theses packages was missing As I saw them been tagged along.
Comment 4 Adam Williamson 2011-09-15 18:14:38 EDT
nic: only ones which will be on media need to make the Beta package set. live images refuse to build if there are bad deps, so I believe the KDE live is okay, otherwise it wouldn't have been generated.
Comment 5 Adam Williamson 2011-09-16 13:50:14 EDT
Discussed at the 2011-09-16 blocker review meeting. Accepted as a blocker per criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install".
Comment 6 Tim Flink 2011-09-16 23:01:47 EDT
updates to fix digikam and libkface have been submitted, need to be pulled in past code freeze
Comment 7 Bruno Wolff III 2011-09-19 12:14:15 EDT
This doesn't seem to be fixed in updates-testing:
yum install -y digikam
Loaded plugins: keys, list-data, merge-conf, priorities, protectbase, refresh-
              : packagekit, remove-with-leaves, upgrade-helper, verify,
              : versionlock
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package digikam.i686 0:2.0.0-3.fc16 will be installed
--> Processing Dependency: digikam-libs(x86-32) = 2.0.0-3.fc16 for package: digikam-2.0.0-3.fc16.i686
--> Processing Dependency: libdigikamcore.so.2 for package: digikam-2.0.0-3.fc16.i686
--> Processing Dependency: libkgeomap.so.1 for package: digikam-2.0.0-3.fc16.i686
--> Processing Dependency: libkface.so.1 for package: digikam-2.0.0-3.fc16.i686
--> Processing Dependency: libdigikamdatabase.so.2 for package: digikam-2.0.0-3.fc16.i686
--> Running transaction check
---> Package digikam-libs.i686 0:2.0.0-3.fc16 will be installed
---> Package libkface.i686 0:2.0.0-3.fc16 will be installed
--> Processing Dependency: libopencv_objdetect.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_calib3d.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_gpu.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_ml.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_legacy.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_contrib.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_highgui.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_flann.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_imgproc.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_core.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_video.so.2.2 for package: libkface-2.0.0-3.fc16.i686
--> Processing Dependency: libopencv_features2d.so.2.2 for package: libkface-2.0.0-3.fc16.i686
---> Package libkgeomap.i686 0:2.0.0-3.fc16 will be installed
fedora/filelists_db                                      |  19 MB     00:02     

Packages skipped because of dependency problems:
    digikam-2.0.0-3.fc16.i686 from fedora
    digikam-libs-2.0.0-3.fc16.i686 from fedora
    libkface-2.0.0-3.fc16.i686 from fedora
    libkgeomap-2.0.0-3.fc16.i686 from fedora
Comment 8 Bruno Wolff III 2011-09-19 12:21:36 EDT
It looks like digikam-2.0.0-4.fc16 didn't get into updates-testing, but is now queued for updates. I'll test it directly.
Comment 9 Bruno Wolff III 2011-09-19 12:42:57 EDT
I tested digikam-2.0.0-4.fc16 from koji and it does install in f16 stable + updates-testing.
Comment 10 Stephen John Smoogen 2011-09-22 16:59:34 EDT
Today it looks to be broken in install. I did an install, turned on "Fedora 16 - i386" and "Fedora 16-i386-Test Updates"

and got the following logs when trying to install:

14:51:05,487 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_contrib.so.2.2
14:51:05,487 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_imgproc.so.2.2
14:51:05,488 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_ml.so.2.2
14:51:05,488 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_contrib.so.2.2
14:51:05,488 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_legacy.so.2.2
14:51:05,488 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_calib3d.so.2.2
14:51:05,489 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_ml.so.2.2
14:51:05,489 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_core.so.2.2
14:51:05,489 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_flann.so.2.2
14:51:05,489 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_objdetect.so.2.2
14:51:05,490 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_calib3d.so.2.2
14:51:05,490 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_objdetect.so.2.2
14:51:05,490 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_gpu.so.2.2
14:51:05,490 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_hi
ghgui.so.2.2
14:51:05,491 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_imgproc.so.2.2
14:51:05,491 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_video.so.2.2
14:51:05,491 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_video.so.2.2
14:51:05,491 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_highgui.so.2.2
14:51:05,492 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_features2d.so.2.2
14:51:05,492 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_gpu.so.2.2
14:51:05,492 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_legacy.so.2.2
14:51:05,492 WARN anaconda: kipi-plugins-2.0.0-3.fc16.i686 requires libopencv_core.so.2.2
14:51:05,492 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_flann.so.2.2
14:51:05,493 WARN anaconda: libkface-2.0.0-3.fc16.i686 requires libopencv_features2d.so.2.2
Comment 11 Adam Williamson 2011-09-23 13:52:34 EDT
network repos are not considered in the repoclosure test, and aren't blockers.
Comment 12 Adam Williamson 2011-09-23 13:53:12 EDT
oh, and you probably caught it in the 'dead period' between the update going out of updates-testing and going into stable: it's got -3, not -4.
Comment 13 Tim Flink 2011-09-23 14:38:05 EDT
There was an issue when pushing digikam to stable to fix this but that issue has been fixed and this should be resolved with the next push to stable.

Please test with RC2 and close if fixed.
Comment 14 Andre Robatino 2011-09-24 02:10:05 EDT
16 Beta RC2 passes repoclosure and file conflicts tests so this can be closed.

Note You need to log in before you can comment on or make changes to this bug.