Bug 73784 - Flash plugin not working
Flash plugin not working
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
: 73848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-10 15:26 EDT by Sammy
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-10 15:26:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nsplugins-gcc3 patch (1.92 KB, patch)
2002-09-12 13:46 EDT, Sammy
no flags Details | Diff

  None (edit)
Description Sammy 2002-09-10 15:26:43 EDT
I cannot load any .swf file using konqueror from kdebase-3.0.3-8. 
 
Scanned plugins show the flash plugin associated with .swf and .spl 
files. Netscape(7.0)  using the same directory	can view the same  
sites perfectly. Plugins are available globally. I am using flash 5.0r50 
but have the same problem with 5.0r47. This used to work fine.
Comment 1 Bernhard Rosenkraenzer 2002-09-12 05:14:39 EDT
This is because Macromedia use a legacy compiler to build their flash module. 
You can't dynamically load a module that was built with an ancient compiler 
from an application that was built with gcc 3.x. 
 
So the options are getting Macromedia to recompile their module, or even 
better, to release the source so we can do it. 
 
There's nothing we can do about this in Konqueror (other than using a legacy 
compiler to build all of KDE, which has other, worse, drawbacks). 
Comment 2 Bernhard Rosenkraenzer 2002-09-12 05:30:31 EDT
*** Bug 73848 has been marked as a duplicate of this bug. ***
Comment 3 Sammy 2002-09-12 11:11:02 EDT
It seem like there is a patch for this that I tracked down from Mandrake 
Cooker. It just defines few missing symbols to nsplugin when compiling 
with gcc-3.2 such that all plugins compiled with either compiler will work. 
I am now compiling kdebase with this patch to see. It would be nice to 
have this working in 8.0.
Comment 4 Sammy 2002-09-12 13:46:24 EDT
Created attachment 75952 [details]
nsplugins-gcc3 patch
Comment 5 Sammy 2002-09-12 13:47:13 EDT
OK. I applied the patch and recompiled. Flash plugin is now working.

Note You need to log in before you can comment on or make changes to this bug.