Bug 737882 - Firstboot catches all exceptions from s-c-date and doesn't advance then
Summary: Firstboot catches all exceptions from s-c-date and doesn't advance then
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Gracik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 737368 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 10:27 UTC by Nils Philippsen
Modified: 2013-07-04 12:58 UTC (History)
4 users (show)

Fixed In Version: firstboot-17.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of: 734993
Environment:
Last Closed: 2011-09-26 12:38:57 UTC


Attachments (Terms of Use)

Description Nils Philippsen 2011-09-13 10:27:35 UTC
+++ This bug was initially created as a clone of Bug #734993 +++
[skip to the relevant part]
--- Additional comment from nphilipp@redhat.com on 2011-09-09 11:28:05 EDT ---

Meanwhile I could reproduce the problem and it's two-fold, the triggering bug is in s-c-date, but a followup one is in firstboot, specifically in its date module:

[...]
    def apply(self, interface, testing=False):
        if testing:
            return RESULT_SUCCESS

        try:
            rc = self.scd.firstboot_apply()
            if rc == 0 and self.scd.closeParent:
                return RESULT_SUCCESS
            else:
                return RESULT_FAILURE
        except:
            return RESULT_FAILURE
[...]

--> this code catches all exceptions raised from self.scd.firstboot_apply() (which makes debugging hard) and apparently (I'm guessing here) causes firstboot to not advance any further in this step (because of "return RESULT_FAILURE"?).
[...]

I think firstboot should ask the user if they want to skip that step if it catches exceptions and alternatively/additionally offer to report them to e.g. Bugzilla.

Comment 1 Martin Gracik 2011-09-20 11:14:35 UTC
*** Bug 737368 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.