Bug 737890 - Conductor ignores enumerable hwp architecture values
Summary: Conductor ignores enumerable hwp architecture values
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Angus Thomas
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 10:55 UTC by Jan Provaznik
Modified: 2012-01-26 12:15 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-07 12:50:20 UTC


Attachments (Terms of Use)

Description Jan Provaznik 2011-09-13 10:55:19 UTC
Description of problem:
Deltacloud API can return enumerable architecture when asking for hardware profiles. Problem is that conductor uses only 'default' value when searching for proper HW profile and ignores other enum options.

We should update conductor HWP matching methods to support enum architecture. Alternatively deltacloud API could be updated to not return architecture of enum type -> CCing Michal Fojtik and David Lutterkort.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Francesco Vollero 2011-09-20 12:41:12 UTC
It was fixed in deltacloud-client version 0.4.0-1.

Comment 2 wes hayutin 2011-09-20 13:53:42 UTC
Matching Provider Hardware Profiles
Provider Name	Hardware Profile Name	Architecture	Memory	Storage	Virtual CPU
ec2-us-east-1	c1.xlarge	 x86_64	 7168	 1690	 20
mock	m1-large	 x86_64	 7680.0 - 15360	 850, 1024	 2

verified..



[root@unused ~]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-configure-2.0.2-4.20110916125556git5a94390.fc15.noarch
aeolus-conductor-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110919181505git369190d.fc15.noarch
aeolus-all-0.4.0-0.20110919181505git369190d.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
[root@unused ~]#

Comment 3 wes hayutin 2011-09-20 15:38:08 UTC
*** Bug 739177 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.