Bug 739177 - No provider HWPs are present
Summary: No provider HWPs are present
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Angus Thomas
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 17:17 UTC by Matt Wagner
Modified: 2014-08-17 22:27 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-20 15:38:08 UTC


Attachments (Terms of Use)

Description Matt Wagner 2011-09-16 17:17:31 UTC
Description of problem:
After applying the latest updates and switching to a unified deltacloud-core, there are no matching HWPs for any provider. Conductor has its default frontend HWPs, but none match anything.

Version-Release number of selected component (if applicable):
aeolus-conductor-0.4.0-0.20110915151744gitc633685.fc15


How reproducible:
JoeV and I are both hitting it 100%.


Steps to Reproduce:
1. Upgrade to the latest bits from the -testing repo, or build from source
2. Switch to deltacloud-core
3. Run aeolus-configure
  
Actual results:
No provider HWPs are present. Attempting to list matches for the 'hwp1' and 'hwp2' front-end profiles in the Conductor WUI gives an error that none matched. Deployments cannot be launched as there are no matching profiles found.

Expected results:
Provider HWPs are imported and matched.

Additional info:

Comment 1 Matt Wagner 2011-09-16 17:35:04 UTC
Whoa... The Provider HWPs are present:

>> Provider.find_by_name('mock').hardware_profiles.collect{|x| x.external_key}
=> ["m1-small", "m1-large", "m1-xlarge", "opaque"]

The matching just isn't happening.

Comment 2 Matt Wagner 2011-09-16 20:16:20 UTC
So this looks like it's the bug in #736734 in which architecture was "0.0". It seems the RPMs in our repo don't have this fix applied.

Comment 3 wes hayutin 2011-09-20 15:38:08 UTC

*** This bug has been marked as a duplicate of bug 737890 ***


Note You need to log in before you can comment on or make changes to this bug.