Bug 73801 - Doing <SHIFT> + 3 (#) on UK keyboard layout problem
Doing <SHIFT> + 3 (#) on UK keyboard layout problem
Status: CLOSED DUPLICATE of bug 75280
Product: Red Hat Public Beta
Classification: Retired
Component: xchat (Show other bugs)
null
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-10 22:37 EDT by Philip Wyett
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-12 07:00:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This shows the extra pre char emitted when '<SHIFT> + 3' is done in null. (5.71 KB, image/jpeg)
2002-09-12 07:00 EDT, Philip Wyett
no flags Details

  None (edit)
Description Philip Wyett 2002-09-10 22:37:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
When in xchat 1.8.10-8 on UK keyboard layout, if you do '<SHIFT> + 3' to get '#'
sign you end up with 'A#' in the text input line.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Change to UK keyboard layout.
2. Run xchat
3. Connect too a server and channel etc.
4. Do keyboard '<SHIFT> + 3' aka '#'
	

Actual Results:  You see something like: A#

Expected Results:  You should see only: #

Additional info:
Comment 1 Philip Wyett 2002-09-10 22:40:55 EDT
Hmm... Sorry about this the English pounds stirling symbol was changed to # by
bugzilla. I am referring too the UK pounds stirling currency symbol. :)
Comment 2 Mike A. Harris 2002-09-11 07:04:35 EDT
I've just had several engineers from Red Hat UK who use the UK keyboard
layout, and xchat test this out with the latest packages and confirm
that they get the proper British pound symbol, and not the octothorpe
symbol which is found on SHIFT-3 on the US keyboard.

Not sure how you're getting this, but it is not reproduceable so far
on our side.

What locale are you using?  Can you paste the contents of:

/etc/sysconfig/i18n

Thanks in advance.
Comment 3 Mike A. Harris 2002-09-11 07:35:17 EDT
Please provide the above info still, but here is some more info I
dug up...

The characters you're seeing, are 0xc2 0xa3 in hexadecimal.  In the
ISO8859-1 or ISO8859-15 encodings, this will be displayed as a capital
letter A with a circle above it, followed by the british pound symbol.

Our assumption is that this code sequence is a UTF-8 encoded character,
and so I tried to decode it by hand.  Here is how UTF-8 is encoded:

 bytes | bits | representation
     1 |    7 | 0vvvvvvv
     2 |   11 | 110vvvvv 10vvvvvv
     3 |   16 | 1110vvvv 10vvvvvv 10vvvvvv
     4 |   21 | 11110vvv 10vvvvvv 10vvvvvv 10vvvvvv

0xc2 0xa3 in binary is 11000010 10100011

The first byte 11000010 matches the UTF-8 for a 2 byte sequence, so we
will take the vvvvv bits and get 00010, or simply 10.  The second byte
10100011 should begin with 10vvvvvv and it also does.  Masking the lower
6 valid bits off of the second byte gives us 100011.  Putting the two
together gives us 10100011, which is again coincidentally 0xa3, which
is the code for the british pound symbol.

So it looks like you're typing the key, it is properly emitting UTF-8
encoded british pound symbol, and it is not being displayed as unicode,
but as 2 separate 8 bit encoded characters instead of being interpreted
as UTF-8.

The above requested file might shed some light.
Comment 4 Philip Wyett 2002-09-12 06:08:29 EDT
The contents of the file you requested aka '/etc/sysconfig/i18n' are:

LANG="en_GB.UTF-8"
SUPPORTED="en_GB.UTF-8:en_GB:en"
SYSFONT="LatArCyrHeb-16"

This problem does not exist in RH 7.3 when installed on this system. But it is
in null, both pre and post updates on the same system. When I install I am doing
clean installs no upgrade between versions - just for your info. :)

Regards

Philip Wyett
Comment 5 Philip Wyett 2002-09-12 07:00:45 EDT
Created attachment 75905 [details]
This shows the extra pre char emitted when '<SHIFT> + 3' is done in null.
Comment 6 Mike A. Harris 2002-11-01 01:25:25 EST

*** This bug has been marked as a duplicate of 75280 ***

Note You need to log in before you can comment on or make changes to this bug.