Bug 738027 - [as5] Unable to collect most of the metrics on the clustered web app contexts
Summary: [as5] Unable to collect most of the metrics on the clustered web app contexts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins
Version: 3.0.1
Hardware: Unspecified
OS: Unspecified
medium
unspecified vote
Target Milestone: ---
: ---
Assignee: Lukas Krejci
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: 740135 743764
TreeView+ depends on / blocked
 
Reported: 2011-09-13 16:32 UTC by Lukas Krejci
Modified: 2012-02-07 19:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 737996
: 769940 (view as bug list)
Environment:
Last Closed: 2012-02-07 19:25:40 UTC


Attachments (Terms of Use)
Screenshot (134.06 KB, image/png)
2011-11-10 10:06 UTC, Sunil Kondkar
no flags Details

Description Lukas Krejci 2011-09-13 16:32:24 UTC
+++ This bug was initially created as a clone of Bug #737996 +++

Description of problem:

When a web application is clustered, RHQ is unable to collect metrics like the number of active sessions.

This is due to an inconsistency in the property names returned from the AS's profile service that returns lowercase names when the web app context is not clustered (e.g. "activeSessions") but when it is clustered the property names start with an uppercase letter (e.g. "ActiveSessions").

This has been filed as a bug in the EAP:
https://issues.jboss.org/browse/JBPAPP-7172

However, RHQ should be robust enough to handle such differences.

Version-Release number of selected component (if applicable):
as5 plugin in all versions

How reproducible:
always

Steps to Reproduce:
1. Start JBoss AS 5 or up in the "all" profile (so that clustering is enabled)
2. Deploy the attached test WAR.
3. Wait for some metrics to be collected
  
Actual results:
Active Sessions and other metrics are never collected

Expected results:
All metrics are collected according to their schedules

Additional info:

Comment 1 Lukas Krejci 2011-09-13 16:41:55 UTC
commit 53b5a8e2c7ae739a83fa2ff98f2682b5d06fb61e
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Tue Sep 13 18:33:14 2011 +0200

    BZ 738027 - Working around the property names inconsistency in the clustered web app contexts.

Comment 2 Sunil Kondkar 2011-11-10 10:05:05 UTC
Verified on build#5 (Version: 4.2.0.JON300-SNAPSHOT Build Number: ed8ff45)
(https://hudson.qa.jboss.com/hudson/view/JON3%20Core/job/rhq-release-gwt-locales/5/)

Started EAP 5.1.1 with "all" profile and deployed the attached test WAR.
Waited for some time and verified that the metrics like 'Currently Active
Sessions' and other metrics are collected and displayed.

Please refer the attached screenshot.

Comment 3 Sunil Kondkar 2011-11-10 10:06:08 UTC
Created attachment 532771 [details]
Screenshot

Comment 4 Mike Foley 2012-02-07 19:25:40 UTC
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.