Bug 73805 - xinetd fail to launch services
xinetd fail to launch services
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
: 74727 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-11 03:06 EDT by Eric Doutreleau
Modified: 2014-08-31 19:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Doutreleau 2002-09-11 03:06:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
From time to time xinetd failed to launch services.
It s totally freeze and doesn't spawn processes it should do

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. launch amcheck on the backup server
2. 
3.
	

Actual Results:  no response from the client

Expected Results:  The client should say that it s ok

Additional info:

restarting xinetd "solve" the problem but it s not really an issue.

It seems somewhat related with the log rotation.
If i don't make log with my mail server i didn't see at all that problem
but i really need that log.
Comment 1 Eric Doutreleau 2002-10-12 05:34:23 EDT
Well i solve the problem with upgrading to the last version of xinetd.
I can provide u the rpm i made of it
Comment 2 Eric Doutreleau 2002-10-12 07:22:58 EDT
the version is the 3.2.9 and here is what is related on my problem on
the changelog of the 3.2.9

*  Fixed a race when there's 1 service configured and it is a wait service.
Comment 3 Eric Doutreleau 2002-10-12 07:26:10 EDT
*** Bug 74727 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2002-10-23 11:57:10 EDT
Same problem.

I have RH 7.2, xinetd-2.3.9-0.72 (btw, Eric.Doutreleau@int-evry.fr wrote 3.2.9, 
was a mistake?)

From time to time some service under xinetd (rsync, proftpd) hangs until I 
restart xinetd.

Here is a dump of ps during a hang of proftpd:

ps axf
...
  770 ?        S      0:00 xinetd -stayalive -reuse -pidfile /var/run/xinetd.pid
16756 ?        ZN     0:00  \_ [proftpd <defunct>]
...

The problem started when I upgraded xinetd. I downgraded xinetd and all seem to 
work fine...
Comment 5 Mike Bird 2002-11-14 00:17:01 EST
This is the biggest single complaint on the RH7.2 and RH7.3 systems we maintain ... FTP, POP3, SMTP etc not responding.  We do "service xinetd 
restart" when necessary and have a cron job to do it every hour in case the local pager service is down and we are unaware of the problem.  Seems 
to have gotten slightly worse with latest 2.3.9-0.73 update.

I know xinetd is supposed to shut off a service when it encounters a DOS attack.  The problems are (1) it never seems to resume the service and 
(2) it sometimes shuts off all services instead of the one being attacked.
Comment 6 Bill Nottingham 2006-08-04 16:36:53 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.