Bug 738056 - Luci creates wrong cluster.conf file
Summary: Luci creates wrong cluster.conf file
Keywords:
Status: CLOSED DUPLICATE of bug 682843
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 6.4
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 18:27 UTC by Mateus Luvison
Modified: 2012-02-10 17:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-10 17:58:47 UTC


Attachments (Terms of Use)

Description Mateus Luvison 2011-09-13 18:27:11 UTC
Description of problem:
Luci creates wrong config in cluster.conf with Samba Server Resource.

Version-Release number of selected component (if applicable):
luci-0.22.2-14.el6

Steps to Reproduce:
1. Resources -> add -> Samba Server
  
Actual results:
/etc/cluster/cluster.conf

<smb config_file="/etc/samba/smb.conf" name="samba" shutdown_wait="0"/>

Expected results:
/etc/cluster/cluster.conf

<samba config_file="/etc/samba/smb.conf" name="samba" shutdown_wait="0"/>

Additional info:

[root@server-01 cluster]# ccs_config_validate -f /etc/cluster/cluster.conf
Relax-NG validity error : Extra element rm in interleave
tempfile:25: element rm: Relax-NG validity error : Element cluster failed to validate content
Configuration fails to validate

Comment 1 Ryan McCabe 2012-02-10 17:58:47 UTC

*** This bug has been marked as a duplicate of bug 682843 ***


Note You need to log in before you can comment on or make changes to this bug.