Bug 738402 - fedpkg tag -l yields a traceback
Summary: fedpkg tag -l yields a traceback
Keywords:
Status: CLOSED DUPLICATE of bug 717528
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 17:47 UTC by Garrett Holmstrom
Modified: 2013-01-10 06:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 23:54:54 UTC


Attachments (Terms of Use)

Description Garrett Holmstrom 2011-09-14 17:47:24 UTC
Description of problem:
``fedpkg tag -l'' with no more arguments prints a traceback:

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 1495, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 721, in tag
    pyfedpkg.list_tag(args.tag)
  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 750, in list_tag
    _run_command(cmd)
  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 210, in _run_command
    ' '.join(cmd))
TypeError: sequence item 3: expected string, NoneType found


Version-Release number of selected component (if applicable):
fedpkg-0.5.9.2-2.fc14.noarch


How reproducible:
Always


Steps to Reproduce:
1. fedpkg tag -l
The error occurs whether inside a git repository or not.

  
Actual results:
Traceback (see description)


Expected results:
A list of git tags

Comment 1 Jesse Keating 2011-09-14 23:54:54 UTC

*** This bug has been marked as a duplicate of bug 717528 ***


Note You need to log in before you can comment on or make changes to this bug.