Bug 73858 - gnome-terminal crash
gnome-terminal crash
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 75871 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-12 06:47 EDT by Joe Orton
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 17:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2002-09-12 06:47:37 EDT
gnome-terminal crashed whilst I was composing a mail in pico (via mutt), I'll
try and reproduce the crash, but here is the backtrace from bug-buddy if that's
any use.

Backtrace was generated from '/usr/bin/gnome-terminal'

(no debugging symbols found)...[New Thread 8192 (LWP 2024)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x408ecc63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x40236ff5 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#4  0x408ee47e in __pthread_sighandler () from /lib/i686/libpthread.so.0
#5  <signal handler called>
#6  0x42028cc1 in kill () from /lib/i686/libc.so.6
#7  0x408eb07d in raise () from /lib/i686/libpthread.so.0
#8  0x4202a019 in abort () from /lib/i686/libc.so.6
#9  0x4093e476 in g_logv () from /usr/lib/libglib-2.0.so.0
#10 0x4093e4b4 in g_log () from /usr/lib/libglib-2.0.so.0
#11 0x40036a19 in vte_sequence_handler_cd () from /usr/lib/libvte.so.2
#12 0x4003c78d in vte_terminal_handle_sequence () from /usr/lib/libvte.so.2
#13 0x4003d58e in vte_terminal_process_incoming () from /usr/lib/libvte.so.2
#14 0x40938c83 in g_idle_dispatch () from /usr/lib/libglib-2.0.so.0
#15 0x40935f65 in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
#16 0x40936f98 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#17 0x409372ad in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#18 0x40937a1f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#19 0x4043939f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x08058256 in main ()
#21 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

Thread 1 (Thread 8192 (LWP 2024)):
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
No symbol table info available.
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x408ecc63 in waitpid () from /lib/i686/libpthread.so.0
No symbol table info available.
#3  0x40236ff5 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#4  0x408ee47e in __pthread_sighandler () from /lib/i686/libpthread.so.0
No symbol table info available.
#5  <signal handler called>
No symbol table info available.
#6  0x42028cc1 in kill () from /lib/i686/libc.so.6
No symbol table info available.
#7  0x408eb07d in raise () from /lib/i686/libpthread.so.0
No symbol table info available.
#8  0x4202a019 in abort () from /lib/i686/libc.so.6
No symbol table info available.
#9  0x4093e476 in g_logv () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#10 0x4093e4b4 in g_log () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#11 0x40036a19 in vte_sequence_handler_cd () from /usr/lib/libvte.so.2
No symbol table info available.
#12 0x4003c78d in vte_terminal_handle_sequence () from /usr/lib/libvte.so.2
No symbol table info available.
#13 0x4003d58e in vte_terminal_process_incoming () from /usr/lib/libvte.so.2
No symbol table info available.
#14 0x40938c83 in g_idle_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#15 0x40935f65 in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#16 0x40936f98 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#17 0x409372ad in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#18 0x40937a1f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#19 0x4043939f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#20 0x08058256 in main ()
No symbol table info available.
#21 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6
No symbol table info available.
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
Comment 1 Joe Orton 2002-09-12 06:58:13 EDT
I thought this might be to do with the fact that I'd just hit the "Insert" key
and found it did Surprising Things, but I can't reproduce the crash.

gnome-terminal-2.0.1-5
vte-0.8.19-1
Comment 2 Nalin Dahyabhai 2002-10-17 19:10:55 EDT
*** Bug 75871 has been marked as a duplicate of this bug. ***
Comment 3 Marie 2003-02-25 22:02:04 EST
I believe that this bug has been solved in the gnome source tree.  

See:   http://bugzilla.gnome.org/show_bug.cgi?id=94509

for details.

Incidentally, this can be reproduced fairly easily by ssh to a Solaris box:

sciences> uname -a
SunOS sciences 5.8 Generic_108528-12 sun4u sparc

Run emacs (in the TTY window) and resize the window.  It may take a few
different resized, but usually I can get to crash in anywhere from 1-5 resize
events.

Note You need to log in before you can comment on or make changes to this bug.