Bug 73892 - /usr/libexec not owned by any package
Summary: /usr/libexec not owned by any package
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: filesystem   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 73984
TreeView+ depends on / blocked
 
Reported: 2002-09-12 23:05 UTC by Enrico Scholz
Modified: 2014-03-17 02:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-06 08:26:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-12 23:05:14 UTC
Description of Problem:

The /usr/libexec directory is used by a lot of packages but not owned by them:

| $ rpm -qf /usr/libexec/* |wc
|    22      50     516
| $ rpm -qf /usr/libexec
| file /usr/libexec is not owned by any package

Although this directory is not specified by the LHS, it should be owned by a
base-package like filesystem or glibc-common (please reassign if the latter
seems to be more properly).

Orphaned directories are a nuisances on package-removal and in the hands of a
paranoid sysadmin who uses 'umask 077'...


Version-Release number of selected component (if applicable):

filesystem-2.1.6-5

Comment 1 Bill Nottingham 2002-11-20 21:15:47 UTC
Will be fixed in 2.2.0-1.


Note You need to log in before you can comment on or make changes to this bug.