This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 739162 - RFE: LVM RAID - Support snapshot of RAID
RFE: LVM RAID - Support snapshot of RAID
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jonathan Earl Brassow
Corey Marthaler
: FutureFeature
Depends On: 785182 807069 811669
Blocks: 732458 756082
  Show dependency treegraph
 
Reported: 2011-09-16 12:04 EDT by Jonathan Earl Brassow
Modified: 2012-08-27 10:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.95-1.el6
Doc Type: Enhancement
Doc Text:
New Feature to 6.3. No documentation required. Bug 732458 is the bug that requires a release note for the RAID features. Other documentation is found in the LVM manual. Operational bugs need no documentation because they are being fixed before their initial release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2011-09-16 12:04:46 EDT
Make it possible to take a snapshot of RAID targets (RAID 1/4/5/6).
Comment 1 Jonathan Earl Brassow 2011-09-16 12:12:48 EDT
Release criteria (test requirements):

Ensure that snapshots can be taken of each of the different RAID types (raid1, raid4, raid5, raid5_ls, raid5_la, raid5_rs, raid5_ra, raid6, raid6_zr, raid6_nr, raid6_nc) - that they can be created and remove.  In short, the same snapshot testing should be performed on RAID that is performed on linear or other devices.
Comment 4 Jonathan Earl Brassow 2012-01-27 18:41:01 EST
All userspace code is in place for snapshots as of the 2.02.89 release.  The kernel has a know issue however.  That is filed under bug 785182 and is blocking this bug.
Comment 8 Jonathan Earl Brassow 2012-04-23 14:19:32 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
New Feature to 6.3.  No documentation required.

Bug 732458 is the bug that requires a release note for the RAID features.  Other documentation is found in the LVM manual.

Operational bugs need no documentation because they are being fixed before their initial release.
Comment 13 Corey Marthaler 2012-05-23 17:14:58 EDT
Basic snapshot regression tests have now passed on raid origin volumes with the latest kernel/lvm rpms. Marking verified.

2.6.32-274.el6.x86_64

lvm2-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-libs-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
lvm2-cluster-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
udev-147-2.41.el6    BUILT: Thu Mar  1 13:01:08 CST 2012
device-mapper-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
device-mapper-event-libs-1.02.74-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
cmirror-2.02.95-10.el6    BUILT: Fri May 18 03:26:00 CDT 2012
Comment 15 errata-xmlrpc 2012-06-20 10:59:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html

Note You need to log in before you can comment on or make changes to this bug.