Bug 785182 - DM RAID: Performing multiple suspend/resume cycles on a dm RAID device causes memory corruption
DM RAID: Performing multiple suspend/resume cycles on a dm RAID device causes...
Status: CLOSED DUPLICATE of bug 789409
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Jonathan Earl Brassow
Red Hat Kernel QE team
:
Depends On:
Blocks: 732458 739162
  Show dependency treegraph
 
Reported: 2012-01-27 09:58 EST by Jonathan Earl Brassow
Modified: 2012-08-27 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 17:22:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my crashlog. The kernel is 2.6.32-220.4.1.el6.x86_64 (4.89 KB, text/plain; charset=ISO-8859-2)
2012-02-06 04:58 EST, Mikulas Patocka
no flags Details

  None (edit)
Description Jonathan Earl Brassow 2012-01-27 09:58:49 EST
Steps to reproduce:
1) lvcreate --type raid1 -m 1 -L 500M -n lv vg
2) dmsetup suspend vg-lv
3) dmsetup resume vg-lv  ** KERNEL OPPS **

It may be necessary to repeat steps 2 & 3.
Comment 2 Mikulas Patocka 2012-02-06 04:56:56 EST
I managed to reproduce the bug. In function bitmap_daemon_work, just after the "/* skip this page unless it's marked as needing cleaning */" comment, page is a wild pointer, pointing to 0x0000006f0000006f. This should be forwarded to the developers of md subsystem, because they have best knowledge of their code.
Comment 3 Mikulas Patocka 2012-02-06 04:58:11 EST
Created attachment 559583 [details]
my crashlog. The kernel is 2.6.32-220.4.1.el6.x86_64
Comment 5 Jonathan Earl Brassow 2012-02-10 17:22:21 EST
Missed this bug when creating bug 789409.  That bug has all the acks already and i've described the patch I sent upstream there.

*** This bug has been marked as a duplicate of bug 789409 ***

Note You need to log in before you can comment on or make changes to this bug.