Bug 739172 - Allow separate fractional attrs to be defined for incremental and total protocols
Allow separate fractional attrs to be defined for incremental and total proto...
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Replication - Fractional (Show other bugs)
1.2.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
: 739176 (view as bug list)
Depends On:
Blocks: 739959 389_1.2.10
  Show dependency treegraph
 
Reported: 2011-09-16 12:58 EDT by Nathan Kinder
Modified: 2015-12-07 11:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 739959 (view as bug list)
Environment:
Last Closed: 2015-12-07 11:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (18.34 KB, patch)
2011-09-16 13:08 EDT, Nathan Kinder
nhosoi: review+
Details | Diff

  None (edit)
Description Nathan Kinder 2011-09-16 12:58:44 EDT
When using fractional replication, there is a single list of attributes to exclude that is used for both total update and incremental updated replication protocols.  While this is generally what one wants to do, it would be nice to have the ability to have separate attribute lists for each protocol.

In the case where you are using a plug-in like memberOf, you want to exclude the memberOf attribute from replication to allow each replica to generate it's own memberOf attributes.  This makes sense for the incremental update protocol, but there is no reason to exclude it from total update, as the memberOf consistency is in a known good state.  If we could replicate memberOf for total update, there would be no need to run a potentially costly memberOf fixup task on each replica after it is initialized.
Comment 1 Nathan Kinder 2011-09-16 13:08:17 EDT
Created attachment 523589 [details]
Patch
Comment 2 Nathan Kinder 2011-09-16 13:28:29 EDT
*** Bug 739176 has been marked as a duplicate of this bug. ***
Comment 3 Rich Megginson 2011-09-16 13:36:39 EDT
If you specify a list of fractional attributes for incremental protocol, and you do not specify a list for total protocol, will total protocol use the list of the incremental attributes?
Comment 4 Nathan Kinder 2011-09-16 13:42:55 EDT
(In reply to comment #3)
> If you specify a list of fractional attributes for incremental protocol, and
> you do not specify a list for total protocol, will total protocol use the list
> of the incremental attributes?

Yes.  I did this to remain backwards compatible.  I don't want someone upgrading to suddenly find that attributes they want completely excluded (like passwords) are being pushed to replicas during initialization.
Comment 5 Nathan Kinder 2011-09-16 16:46:42 EDT
Pushed to master.  Thanks to Rich and Noriko for their reviews!

Counting objects: 25, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (13/13), done.
Writing objects: 100% (13/13), 2.19 KiB, done.
Total 13 (delta 11), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/ds.git
   6120b3d..0157534  master -> master
Comment 8 Sankar Ramalingam 2011-12-06 05:24:31 EST
Marking this bug as Verified since the clone has been verified successfully.
https://bugzilla.redhat.com/show_bug.cgi?id=739959
Comment 9 Rich Megginson 2012-01-10 15:33:34 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/250

Note You need to log in before you can comment on or make changes to this bug.