Bug 739270 - Alternate Tab extension doesn't work
Summary: Alternate Tab extension doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 752992 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 03:55 UTC by Charles R. Anderson
Modified: 2011-12-23 03:26 UTC (History)
12 users (show)

Fixed In Version: gnome-shell-extensions-3.2.3-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-23 03:26:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 661281 None None None Never

Description Charles R. Anderson 2011-09-17 03:55:05 UTC
Description of problem:

After a gnome-shell update (not sure which one), alternate tab doesn't work.  When the extension is enabled, I cannot tab at all--nothing appears and it is isn't possible to switch applications via Alt-Tab.  Disabling the extension allows the standard Alt-Tab behavior to work again.

Version-Release number of selected component (if applicable):
gnome-shell-3.1.91-2.fc16.x86_64
gnome-shell-extension-alternate-tab-3.1.91-2.fc16.noarch

How reproducible:
always

Steps to Reproduce:
1. Enable AlternateTab extension
2. hit Alt-Tab
  
Actual results:
Nothing appears.  Can't change applications via Alt-Tab.

Expected results:
Alt-Tab should pop up the window switcher.

Additional info:

Other installed extension packages:

gnome-shell-extension-alternative-status-menu-3.1.91-2.fc16.noarch
gnome-shell-extension-common-3.1.91-2.fc16.noarch
gnome-shell-extension-cpu-temperature-0-0.1.git712153f.fc16.noarch
gnome-shell-extension-places-menu-3.1.91-2.fc16.noarch
gnome-shell-extension-presentation-mode-0-0.2.gitc3ce6b2.fc16.noarch

Only these extensions are actually enabled:

AlternateTab
Places Status Indicator Extension

Comment 1 Ismael Olea 2011-09-21 10:34:52 UTC
problems in f15 too

hiting alt-tab kills gnome-shell

gnome-shell-extensions-alternate-tab-3.0.0-5.6d56cfgit.fc15
gnome-shell-extension-common-3.0.2-3.20110630git939994d0.fc15.noarch
gnome-shell-3.0.2-4.fc15.i686

Comment 2 Mohamed El Morabity 2011-10-12 13:21:53 UTC
Thanks for this bug report. The bug is known upstream:
   https://bugzilla.gnome.org/show_bug.cgi?id=661281

Comment 3 Fedora Update System 2011-11-10 09:32:53 UTC
gnome-shell-extensions-3.2.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.2.0-2.fc16

Comment 4 Fedora Update System 2011-11-11 01:24:50 UTC
Package gnome-shell-extensions-3.2.0-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extensions-3.2.0-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15734
then log in and leave karma (feedback).

Comment 5 Brad Hess 2011-11-11 16:57:16 UTC
See comments at https://admin.fedoraproject.org/updates/FEDORA-2011-15734 -- the update does not fix this bug.

Comment 6 Mohamed El Morabity 2011-11-19 12:42:42 UTC
*** Bug 752992 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2011-11-20 23:54:15 UTC
gnome-shell-extensions-3.2.0-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Mohamed El Morabity 2011-11-30 01:46:59 UTC
I invite you to test the following update:
   https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.2.1-1.fc16
If it doesn't solve the bug, you are *strongly* encouraged to report your issues upstream, in the following open bug report:
   https://bugzilla.gnome.org/show_bug.cgi?id=661281
The fix described in this bug report and supposed to solve the problem is included in the package given above. Unfortunately, it doesn't seem to work, according to its comments...

Comment 9 J Robinson 2011-12-11 02:33:00 UTC
Still not working as of newly released 3.2.1-1 version.
Have added notes to https://bugzilla.gnome.org/show_bug.cgi?id=661281 bug report.

Comment 10 Alex Lancaster 2011-12-14 22:44:00 UTC
gnome-shell-extension-alternate-tab "works" in that it doesn't break "Alt-Tab" behaviour completely, but I am unable to switch it from the default mode (all_thumbnails) to the "workspace_icons", even after setting the appropriate value in dconf-editor and restarting GNOME shell (or logging out and logging back in).  This  *was* working prior to the 3.2.1-1 update.

Comment 11 Alex Lancaster 2011-12-14 22:47:26 UTC
OK it appears that the workaround given in https://bugzilla.gnome.org/show_bug.cgi?id=661281#c27  appears to fix it, allowing "workspace_icons" to work, so it appears to be fixed in upstream git.

Comment 12 Alex Lancaster 2011-12-14 22:52:14 UTC
It appears that there may not be a new official release with this patch until gnome-shell 3.3, so perhaps this patch could be backported to the Fedora package in the meantime.

Comment 13 Fedora Update System 2011-12-18 16:40:49 UTC
gnome-shell-extensions-3.2.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.2.3-1.fc16

Comment 14 Fedora Update System 2011-12-21 16:55:12 UTC
Package gnome-shell-extensions-3.2.3-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extensions-3.2.3-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17229/gnome-shell-extensions-3.2.3-1.fc16
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2011-12-23 03:26:44 UTC
gnome-shell-extensions-3.2.3-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.