Bug 739478 - Review request: rubygem-jammit - Industrial Strength Asset Packaging for Rails
Summary: Review request: rubygem-jammit - Industrial Strength Asset Packaging for Rails
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 725768
Blocks: FE-DEADREVIEW 705521
TreeView+ depends on / blocked
 
Reported: 2011-09-19 08:21 UTC by Bohuslav "Slavek" Kabrda
Modified: 2016-10-11 10:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-11 10:22:56 UTC


Attachments (Terms of Use)

Description Bohuslav "Slavek" Kabrda 2011-09-19 08:21:31 UTC
SPEC: http://bkabrda.fedorapeople.org/jammit/rubygem-jammit.spec
SRPM: http://bkabrda.fedorapeople.org/jammit/rubygem-jammit-0.6.3-1.fc15.src.rpm

Description:
Jammit is an industrial strength asset packaging library for Rails,
providing both the CSS and JavaScript concatenation and compression that
you'd expect, as well as YUI Compressor and Closure Compiler compatibility,
ahead-of-time gzipping, built-in JavaScript template support, and optional
Data-URI / MHTML image embedding.

Note:
This package is a bit tricky. Two tests fail without rubygem-closure-compiler installed, four more tests fail when testing with Rails >= 3. Jammit can however be used even without closure-compiler, so I didn't list it in BR: nor R: sections. The failing tests are already reported (see links in comments in spec file).
Also, please note, that you need to install rubygem-yui-compressor (https://bugzilla.redhat.com/show_bug.cgi?id=725768) and you currently need to place yuicompressor-2.4.4.jar under /usr/share/java/ manually to rebuild this package.

Comment 1 Vít Ondruch 2011-09-21 06:13:26 UTC
Taking this for a review.

Comment 2 James Laska 2011-10-04 19:38:22 UTC
(In reply to comment #1)
> Taking this for a review.

Any updates?

Comment 3 Vít Ondruch 2011-10-05 06:05:26 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Taking this for a review.
> 
> Any updates?

Actually this is blocked by review of rhbz#725768 and this is blocked by rhbz#725739 which block everything :/

Comment 4 Bohuslav "Slavek" Kabrda 2012-11-12 10:49:48 UTC
The yui-compressor dependency has been removed in upstream [1], so it seems that we will be able to proceed, once a new version is released [2]. I will try to look into packaging the new dependencies in the meanwhile.

[1] https://github.com/documentcloud/jammit/commit/28ddf14bc7a33d25734f55759429657997fa6ec5
[2] https://github.com/documentcloud/jammit/issues/239

Comment 5 Vít Ondruch 2016-10-11 10:22:56 UTC
I guess you don't mind me closing this review.


Note You need to log in before you can comment on or make changes to this bug.