Bug 739501 - virt-install cannot mount the kickstart file on the root with --initrd-inject=/path/to/ks.cfg --extra-args ks=file:/ks.cfg
virt-install cannot mount the kickstart file on the root with --initrd-inject...
Status: CLOSED DUPLICATE of bug 739507
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 06:02 EDT by Hongqing Yang
Modified: 2011-09-19 06:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-19 06:47:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hongqing Yang 2011-09-19 06:02:36 EDT
Description of problem:

virt-install \
   --name demo \
   --vcpus 4 \
   --ram 1024 \
   --disk path=/var/lib/libvirt/images/demo.img,size=8 \
   --location /media \
   --extra-args " ks=http://10.66.13.140/ks.cfg"  \
   --channel tcp,host=127.0.0.1:6080,mode=connect,target_type=virtio,name=org.fedoraproject.anaconda.log.0


or

virt-install \
   --name demo \
   --vcpus 4 \
   --ram 1024 \
   --disk path=/var/lib/libvirt/images/demo.img,size=8 \
   --location /media \
   --initrd-inject=/tmp/autoqa/log/ks.cfg \
   --extra-args ks=file:/ks.cfg"  \
   --channel tcp,host=127.0.0.1:6080,mode=connect,target_type=virtio,name=org.fedoraproject.anaconda.log.0


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a guest with the script above
2. check the root directory /
3. there is no kickstart file mounted there
  
Actual results:

This works well with F15, but does not work with F16.
The host is F15
the libvirt version is  libvirt-0.8.8-7.fc15.x86_64

Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-09-19 06:47:50 EDT

*** This bug has been marked as a duplicate of bug 739507 ***

Note You need to log in before you can comment on or make changes to this bug.