Bug 739507 - virt-install --initrd-inject doesnt work with f16 install tree
virt-install --initrd-inject doesnt work with f16 install tree
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 739501 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-19 06:29 EDT by Hongqing Yang
Modified: 2011-12-04 22:20 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-04 22:20:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hongqing Yang 2011-09-19 06:29:17 EDT
Description of problem:
virt-install cannot mount kickstart file to root directory with option initrd-inject with the following scripts

virt-install \
   --name demo \
   --vcpus 4 \
   --ram 1024 \
   --disk path=/var/lib/libvirt/images/demo.img,size=8 \
   --location /media \
   --initrd-inject=/tmp/autoqa/log/ks.cfg \
   --extra-args  ks=file:/ks.cfg  

it works well with F15, but do not work with F16

Version-Release number of selected component (if applicable):
libvirt-0.8.8-7.fc15.x86_64


How reproducible:


Steps to Reproduce:
1. create guest with the script above
2. check the guest root directory
3. kickstart file does not exist
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2011-09-19 06:47:51 EDT
*** Bug 739501 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lalancette 2011-09-19 09:11:37 EDT
This is actually a "bug" with the python-virtinst package (though it equally might be a bug with the Fedora-16 kernel).  Switching component to python-virtinst for now.
Comment 4 Cole Robinson 2011-10-06 12:28:38 EDT
Never mind, that commit is basically useless.

According to https://bugzilla.redhat.com/show_bug.cgi?id=736318 the f16 initrd format is substancially different so I don't really have any ideas.
Comment 5 Hongqing Yang 2011-12-04 22:20:06 EST
verified python-virtinst-0.500.6-2.fc15.noarch
it works now.

Note You need to log in before you can comment on or make changes to this bug.