Bug 739572 - abrt-cli fails to report problem in the command line
Summary: abrt-cli fails to report problem in the command line
Keywords:
Status: CLOSED DUPLICATE of bug 739562
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.2
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Moskovcak
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 14:37 UTC by Miroslav Svoboda
Modified: 2015-10-06 02:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 15:29:54 UTC


Attachments (Terms of Use)
Screenshot of console output. (31.46 KB, image/png)
2011-09-19 14:37 UTC, Miroslav Svoboda
no flags Details

Description Miroslav Svoboda 2011-09-19 14:37:32 UTC
Created attachment 523847 [details]
Screenshot of console output.

Description of problem:
The abrt-cli application does not behave as expected. I encountered two issues while testing abrt-cli for documentation purposes.
Firstly, when running the "abrt-cli report /problem_data_directory" command in a terminal window in GNOME desktop GUI, the problem report opens up the ABRT GUI instead of proceeding with the reporting process in the terminal.
Secondly, when running the "abrt-cli report /problem_data_directory" command in the virtual console or in the terminal connected remotely via ssh, ABRT does not proceed with reporting as expected but fails with the "Invalid input, program exiting..." message.

Version-Release number of selected component (if applicable):
[arcanus@rhel6 ~]$ rpm -qa|grep abrt
abrt-gui-2.0.4-10.el6.x86_64
abrt-addon-python-2.0.4-10.el6.x86_64
abrt-addon-ccpp-2.0.4-10.el6.x86_64
abrt-cli-2.0.4-10.el6.x86_64
abrt-libs-2.0.4-10.el6.x86_64
abrt-addon-kerneloops-2.0.4-10.el6.x86_64
abrt-2.0.4-10.el6.x86_64
abrt-desktop-2.0.4-10.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1-a. Open up terminal window in desktop GUI and make sure that there exist problem data on the system, for example:

~]$ abrt-cli list --full
Directory:      /home/<user>/.abrt/spool/<problem_data_directory>
count:          1
executable:     /usr/bin/gedit
package:        gedit-2.28.4-3.el6
time:           Sun 18 Sep 2011 03:59:57 PM CEST
uid:            500

2-a. Run the "abrt-cli report" command on existing problem data, for example:

~]$ abrt-cli report /home/<user>/.abrt/spool/<problem_data_directory>

1-b. Log in the virtual console or log in the system remotely using the ssh protocol

2-b. Run the "abrt-cli report" command on existing problem data

~]$ abrt-cli report /home/<user>/.abrt/spool/<problem_data_directory>
  
Actual results:
a) ABRT opens up the problem description window in ABRT GUI.

b) Usage: abrt-cli report [options] [<dump-dir>]...                                                                                                                                                                     
  -v, --verbose               Be verbose                                                                                                                                                                           
~]$ How you would like to analyze the problem?
 1) Collect .xsession-errors
 2) Local GNU Debugger
Select analyzer: Select analyzer: Select analyzer: Invalid input, program exiting...

Expected results:
ab) ABRT proceeds with the problem reporting process in the command line:
How you would like to analyze the problem?
 1) Local GNU Debugger
 2) Retrace Server
Select analyzer:_

Additional info:

Comment 2 Jiri Moskovcak 2011-09-19 15:29:54 UTC

*** This bug has been marked as a duplicate of bug 739562 ***


Note You need to log in before you can comment on or make changes to this bug.