Bug 739627 - libvirt-lock-sanlock requires augeas
Summary: libvirt-lock-sanlock requires augeas
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: augeas
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Lutterkort
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 738314
TreeView+ depends on / blocked
 
Reported: 2011-09-19 16:37 UTC by Eric Blake
Modified: 2013-04-30 23:42 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-08 02:13:15 UTC


Attachments (Terms of Use)

Description Eric Blake 2011-09-19 16:37:04 UTC
Description of problem:
Libvirt cannot fully support the sanlock lock manager unless augtool is part of RHEL 6.2.  See bug 738314

Version-Release number of selected component (if applicable):
augeas-0.9.0-1.el6
libvirt-lock-sanlock-0.9.4-12.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum install libvirt-lock-sanlock
2.
3.
  
Actual results:
augeas-libs is in RHEL 6.2, but not augeas, which means libvirt-lock-sanlock has a missing dependency

Expected results:
Both augeas and augeas-libs should be in RHEL 6.2.

Additional info:
See also this upstream report:
https://www.redhat.com/archives/libvir-list/2011-September/msg00721.html

Comment 6 David Lutterkort 2011-11-08 02:13:15 UTC
Both libvirt-lock-sanlock and augeas are now in the optional channel, so all is well.


Note You need to log in before you can comment on or make changes to this bug.