Bug 739680 - Misleading error message when uploading subscription manifest
Summary: Misleading error message when uploading subscription manifest
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-19 19:21 UTC by Jeff Weiss
Modified: 2019-09-26 13:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:57:23 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-09-19 19:21:33 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.82-1.git.36.3cfca56.fc14.noarch

How reproducible:


Steps to Reproduce:
1. Create user "admin1", give Administrator role
2. log in as "admin1"
3. upload subscription manifest from 
  http://axiom.rdu.redhat.com/git/gitweb.cgi?p=system-engine;a=blob;f=scripts/test/sample-candlepin-export.zip;h=4451ff79098c1734c2a465e09a0c42fbc6256ae7;hb=HEAD

Actual results:
×There was a format error with your Subscription Manifest

Expected results:
success, or until 729364 is resolved, 
×Pulp::Repository: 401 Unauthorized "Invalid OAuth Credentials"

Additional info:
There's nothing wrong with the subscription manifest format, it works fine if you upload it as admin.

Comment 1 Brad Buckingham 2011-10-05 15:31:07 UTC
commit - f94a94e4022d73ee79f4780c7be40f9411092f73

It appears that bz 729364 has been resolved; therefore, I wasn't able to reproduce the issue as initially reported.

I did, however, make some modifications to improve the error reporting for manifest uploads.  The change is basically to parse the errors that come from Candlepin and include them in the error notice to the user.

For example, 

rather than generate:

"There was a format error with your Subscription Manifest"

generate:

"Subscription manifest upload for provider 'Red Hat' failed.
Reason: Import is older than existing data"

Comment 2 Jeff Weiss 2011-10-24 15:16:48 UTC
Verified, katello-0.1.95-1.git.56.344ea38.el6.x86_64

Comment 5 Mike McCune 2013-08-16 18:16:30 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.