Bug 739793 - subscription-manager --list should blank out the dates when Not Subscribed
subscription-manager --list should blank out the dates when Not Subscribed
Status: CLOSED DUPLICATE of bug 740046
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-19 23:31 EDT by John Sefler
Modified: 2013-01-10 05:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 08:45:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cli list --installed should blank ot the date field like the gui when Not Subscribed (101.60 KB, image/png)
2011-09-19 23:31 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-09-19 23:31:47 EDT
Created attachment 523945 [details]
cli list --installed should blank ot the date field like the gui when Not Subscribed

Description of problem:
The new implementation of subscription-manager list --installed should not report any value for Starting or Expires when Not Subscribed.  This will better match the behavior of the GUI and was in fact the way this function used to behave.

See attached screenshot.

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.9-1.git.26.e7a7723.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Stackable with Awesome OS for x86_64 Bits
Version:            	3.11                     
Arch:               	x86_64                   
Status:             	Not Subscribed           
Starts:             	09/19/2011               
Expires:            	09/19/2011     


^^^^^^^^
Expected the values for Starts: and Expires: to be blank
Comment 3 John Sefler 2011-10-03 08:45:50 EDT

*** This bug has been marked as a duplicate of bug 740046 ***

Note You need to log in before you can comment on or make changes to this bug.