Bug 740046 - wrong Expires date displayed in new list --installed
wrong Expires date displayed in new list --installed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: John Sefler
IDM QE LIST
:
: 739793 (view as bug list)
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-20 15:16 EDT by John Sefler
Modified: 2011-12-06 12:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:24:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
date circled in red should match the dates circled in green (137.90 KB, image/png)
2011-09-20 15:16 EDT, John Sefler
no flags Details
Now the installed dates are blank after the subscribe - not good (116.70 KB, image/png)
2011-09-23 23:18 EDT, John Sefler
no flags Details
The list --installed dates are blank before subscribe and are correct after subscribe (124.09 KB, image/png)
2011-09-26 12:45 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-09-20 15:16:54 EDT
Created attachment 524087 [details]
date circled in red should match the dates circled in green

Description of problem:
After a simple register and subscribe (I used the stage candlepin with stage_test_27 on a workstation and subscribed to the RHELWorkstation), the Expires date in the cli list --installed is wrong.  It does not match the dates on list --consumed nor the gui.

See screenshot date circled in red should match the dates circled in green 


Version-Release number of selected component (if applicable):
[root@jsefler-stage-6workstation ~]# rpm -q subscription-manager
subscription-manager-0.96.9-1.git.32.47bc7e7.el6.x86_64
Comment 1 William Poteat 2011-09-22 13:58:30 EDT
commit 177d3f7ea3dc5026bb7e271ef176400bb0c3e82f in RELH6.2
commit 544a47f5ebf86f942d5a57ddd171db378e87f05b in master
Comment 2 William Poteat 2011-09-22 13:59:37 EDT
    The dates for begin and end for the installed option will be based on the
    same information for both CLI and GUI. No entitlements for an installed
    product results in a blank for both begin and end dates.
    
    Expired, future, partial, and full subscriptions will go with a compiling
    of dates from all availble entitlements for a given product.
Comment 3 John Sefler 2011-09-23 23:18:53 EDT
Created attachment 524705 [details]
Now the installed dates are blank after the subscribe - not good

[root@jsefler-stage-6server ~]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.96.11-1.git.7.15fc9d2.el6.x86_64
subscription-manager-firstboot-0.96.11-1.git.7.15fc9d2.el6.x86_64
subscription-manager-0.96.11-1.git.7.15fc9d2.el6.x86_64


[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux 6 Server
Version:            	6.1                      
Arch:               	x86_64                   
Status:             	Not Subscribed           
Starts:             	                         
Expires:            	                         

[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201308b9ad4a41d37
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad4a41d37
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux 6 Server
Version:            	6.1                      
Arch:               	x86_64                   
Status:             	Subscribed               
Starts:             	                         
Expires:            	                         

                        ^^^^^^^^^^
NOW, THE CLI START AND END DATES LISTED FOR THE INSTALLED PRODUCT ARE BLANK AND STILL DO NOT MATCH THE GUI.  SEE THE CIRCLED GREEN IS GOOD AND RED IS BAD IN THE ATTACHED SCREENSHOT.

Moving back to ASSIGNED
Comment 4 William Poteat 2011-09-26 11:18:40 EDT
Corrected:

RHEL6.2 Commit: b453a8343d68c6a7a54199bc35c1075455a604c6 

Master Commit: 5995b4935f3b549b0b5af9c3f670fe7ff34b56b4
Comment 5 John Sefler 2011-09-26 12:45:39 EDT
Created attachment 524942 [details]
The list --installed dates are blank before subscribe and are correct after subscribe

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.11-1.git.9.b453a83.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager config --server.hostname=subscription.rhn.stage.redhat.com
[root@jsefler-onprem-62server ~]# subscription-manager register --username stage_test_12
Password:
The system has been registered with id: 3cc6b3e3-deca-4a46-a332-bfafe398b9c0 
[root@jsefler-onprem-62server ~]#
[root@jsefler-onprem-62server ~]# subscription-manager list --avail | grep -A4 -B2 RH0103708
ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad4a41d37
Quantity:          	93                       
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
--
ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad7101d3a
Quantity:          	395                      
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
[root@jsefler-onprem-62server ~]# 
[root@jsefler-onprem-62server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Version:            	6.2 Beta                 
Arch:               	x86_64                   
Status:             	Not Subscribed           
Starts:             	                         
Expires:            	                         

[root@jsefler-onprem-62server ~]# subscription-manager subscribe --pool 8a99f981308acf4201308b9ad4a41d37
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad4a41d37
[root@jsefler-onprem-62server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Version:            	6.2 Beta                 
Arch:               	x86_64                   
Status:             	Subscribed               
Starts:             	06/09/2011               
Expires:            	06/08/2012               

[root@jsefler-onprem-62server ~]# 

 ^^^ VERIFIED!
1. The dates of the "Not Subscribed" product are blank
2. The CLI dates of the "Subscribed" product match the dates in the GUI (see attached screenshot)
Comment 6 John Sefler 2011-09-26 13:08:36 EDT
I should also include verification on the dates listed for the consumed subscription.  They should match the dates on the installed product since there is only one entitlement cert covering the product...

[root@jsefler-onprem-62server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Version:            	6.2 Beta                 
Arch:               	x86_64                   
Status:             	Subscribed               
Starts:             	06/09/2011               
Expires:            	06/08/2012               

[root@jsefler-onprem-62server ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Red Hat Enterprise Linux Server
ContractNumber:     	2394344                  
AccountNumber:      	1465502                  
SerialNumber:       	7275017531725819752      
Active:             	True                     
QuantityUsed:       	1                        
Begins:             	06/09/2011               
Expires:            	06/08/2012               

[root@jsefler-onprem-62server ~]# 

YES they match...  moving to VERIFIED
Comment 7 John Sefler 2011-10-03 08:45:50 EDT
*** Bug 739793 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2011-12-06 12:24:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.