This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 739820 - Can't restart from GDM
Can't restart from GDM
Status: CLOSED DUPLICATE of bug 739253
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-20 03:16 EDT by Kamil Páral
Modified: 2011-09-20 05:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-20 05:09:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (411.46 KB, application/octet-stream)
2011-09-20 03:16 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2011-09-20 03:16:19 EDT
Created attachment 523962 [details]
/var/log/messages

Description of problem:
Clean installation of Fedora 16 Beta RC1 i386, default package set. When booted into GDM, can't restart machine. When logged in, can restart machine.

From /var/log/messages:

Sep 20 03:09:38 localhost gdm-simple-greeter[975]: DEBUG(+): GdmGreeterPanel: trying to restart system
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG: system-bus-name::1.14 is inquiring whether system-bus-name::1.34 is authorized for org.freedesktop.consolekit.system.restart
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  user of caller is unix-user:root
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  user of subject is unix-user:gdm
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG: checking whether system-bus-name::1.34 is authorized for org.freedesktop.consolekit.system.restart
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:   0xb6501430
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  subject is in session /org/freedesktop/ConsoleKit/Session1 (local=1 active=0)
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  not authorized
Sep 20 03:09:38 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:
Sep 20 03:09:38 localhost gdm-simple-greeter[975]: DEBUG(+): GdmGreeterPanel: unable to restart system: org.freedesktop.ConsoleKit.Manager.NotPrivileged: Not Authorized
Sep 20 03:09:42 localhost gdm-simple-greeter[975]: DEBUG(+): GdmGreeterPanel: trying to restart system
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG: system-bus-name::1.14 is inquiring whether system-bus-name::1.34 is authorized for org.freedesktop.consolekit.system.restart
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  user of caller is unix-user:root
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  user of subject is unix-user:gdm
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG: checking whether system-bus-name::1.34 is authorized for org.freedesktop.consolekit.system.restart
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:   0xb6f01f78
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  subject is in session /org/freedesktop/ConsoleKit/Session1 (local=1 active=0)
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:  not authorized
Sep 20 03:09:42 localhost dbus-daemon[699]: ** (polkitd:734): DEBUG:
Sep 20 03:09:42 localhost gdm-simple-greeter[975]: DEBUG(+): GdmGreeterPanel: unable to restart system: org.freedesktop.ConsoleKit.Manager.NotPrivileged: Not Authorized

Version-Release number of selected component (if applicable):
gdm-3.1.90-1.fc16.i686
systemd-35-1.fc16.i686
systemd-sysv-35-1.fc16.i686
systemd-units-35-1.fc16.i686
dbus-1.4.10-3.fc16.i686
dbus-glib-0.92-2.fc15.i686
dbus-libs-1.4.10-3.fc16.i686
dbus-python-0.83.0-8.fc15.i686
dbus-x11-1.4.10-3.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. Boot into gdm.
2. Hit restart (or poweroff), nothing happens.
3.
Comment 1 Kamil Páral 2011-09-20 03:18:45 EDT
More information: I installed from DVD.

Proposing as Beta blocker:

All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work
https://fedoraproject.org/wiki/Fedora_16_Beta_Release_Criteria
Comment 2 Andre Robatino 2011-09-20 04:20:49 EDT
Appears to be a duplicate of bug 739253 (I can mark that as a blocker if you want).
Comment 3 Kamil Páral 2011-09-20 05:09:57 EDT
Great catch, Andre, thanks.

*** This bug has been marked as a duplicate of bug 739253 ***

Note You need to log in before you can comment on or make changes to this bug.