This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 739253 - unable to shut down from gdm greeter
unable to shut down from gdm greeter
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 739820 (view as bug list)
Depends On:
Blocks: F16Beta/F16BetaBlocker
  Show dependency treegraph
 
Reported: 2011-09-16 18:40 EDT by Mads Kiilerich
Modified: 2011-10-03 12:02 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 12:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (231.60 KB, application/octet-stream)
2011-09-16 18:40 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2011-09-16 18:40:11 EDT
Created attachment 523657 [details]
/var/log/messages

On a system with latest f16+testing I can't shutdown from the gdm greeter windows. It silently ignores it. I would expect any anonymous user to shut down there - especially when no users are logged in.

Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG: system-bus-name::1.15 is inquiring whether system-bus-name::1.36 is authorized for org.freedesktop.consolekit.system.restart
Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  user of caller is unix-user:root
Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  user of subject is unix-user:gdm
Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG: checking whether system-bus-name::1.36 is authorized for org.freedesktop.consolekit.system.restart
Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:   0x7fe8e00062a0
Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  subject is in session /org/freedesktop/ConsoleKit/Session1 (local=1 active=0)
Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  not authorized
Sep 17 00:19:12 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:
Sep 17 00:19:12 localhost gdm-simple-greeter[1358]: DEBUG(+): GdmGreeterPanel: unable to restart system: org.freedesktop.ConsoleKit.Manager.NotPrivileged: Not Authorized
Sep 17 00:19:23 localhost gdm-simple-greeter[1358]: DEBUG(+): GdmGreeterPanel: trying to restart system
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG: system-bus-name::1.15 is inquiring whether system-bus-name::1.36 is authorized for org.freedesktop.consolekit.system.restart
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  user of caller is unix-user:root
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  user of subject is unix-user:gdm
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG: checking whether system-bus-name::1.36 is authorized for org.freedesktop.consolekit.system.restart
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:   0x10fe930
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  subject is in session /org/freedesktop/ConsoleKit/Session1 (local=1 active=0)
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  not authorized
Sep 17 00:19:23 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:
Sep 17 00:19:23 localhost gdm-simple-greeter[1358]: DEBUG(+): GdmGreeterPanel: unable to restart system: org.freedesktop.ConsoleKit.Manager.NotPrivileged: Not Authorized
Sep 17 00:19:32 localhost gdm-simple-greeter[1358]: DEBUG(+): GdmGreeterPanel: trying to stop system
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG: system-bus-name::1.15 is inquiring whether system-bus-name::1.36 is authorized for org.freedesktop.consolekit.system.stop
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  user of caller is unix-user:root
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  user of subject is unix-user:gdm
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG: checking whether system-bus-name::1.36 is authorized for org.freedesktop.consolekit.system.stop
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:   0x1108900
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  subject is in session /org/freedesktop/ConsoleKit/Session1 (local=1 active=0)
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:  not authorized
Sep 17 00:19:33 localhost dbus-daemon[1045]: ** (polkitd:1055): DEBUG:
Sep 17 00:19:33 localhost gdm-simple-greeter[1358]: DEBUG(+): GdmGreeterPanel: unable to stop system: org.freedesktop.ConsoleKit.Manager.NotPrivileged: Not Authorized

ConsoleKit-0.4.5-1.fc15.x86_64
upower-0.9.13-1.fc16.x86_64
gnome-power-manager-3.1.3-1.fc16.x86_64
gdm-3.1.90-1.fc16.x86_64
systemd-35-1.fc16.x86_64
Comment 1 Andre Robatino 2011-09-20 04:27:42 EDT
Marking as F16 Beta blocker according to the criterion in https://bugzilla.redhat.com/show_bug.cgi?id=739820#c1 (that bug appears to be a duplicate of this one).
Comment 2 Kamil Páral 2011-09-20 05:09:58 EDT
*** Bug 739820 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2011-09-20 17:05:15 EDT
CC ray, as this may be just a gdm issue - not sure who gets to set the CK policy.
Comment 4 Ray Strode [halfline] 2011-09-20 17:57:43 EDT
this should be fixed in 3.1.92 that I built yesterday. mind testing?
Comment 5 Mads Kiilerich 2011-09-20 18:59:50 EDT
I no longer see any power management choices in gdm. In the top right corner there is only input methods and sound volume. I am however not sure it has been caused by gdm 3.1.92 - I might have seen that before. Any idea what can have caused that?t
Comment 6 Andre Robatino 2011-09-20 22:39:36 EDT
Seems to fix it for me. Before updating to 3.1.92, I had two entries , "Restart" and "Shut Down". After, I have three entries, "Suspend", "Restart", and "Shut Down". The latter two work properly, I'm not sure whether Suspend is supposed to work in my VirtualBox guest, or how - I never use suspend normally.
Comment 7 Adam Williamson 2011-09-21 01:06:55 EDT
ray: how 'dangerous' are the other 3.1.92 changes? given that we're deep in beta freeze, might it make sense to backport the fix to 3.1.91 for the beta? I'd hate to break anything else by taking this fix.
Comment 8 Kamil Páral 2011-09-21 07:19:57 EDT
gdm 3.1.92 seems to be working well and fixes this issue. Tested only inside KVM.
Comment 9 Kamil Páral 2011-09-21 09:22:08 EDT
I have tested gdm 3.1.92 on real hardware and it also seems to be working well, but there is no restart/poweroff option! (to tell the truth, it is neither in 3.1.90). I hope it is no further "simplification" from Gnome team.
Comment 10 John Dulaney 2011-09-21 12:36:22 EDT
I'm also not getting a poweroff in 3.1.92.  This is not good, since I prefer to have my laptop off when not in use.
Comment 11 Adam Williamson 2011-09-21 14:34:17 EDT
I see poweroff and restart options in 3.1.92, and they work.
Comment 12 Adam Williamson 2011-09-21 21:01:07 EDT
Discussed at the 2011-09-21 go/no-go meeting (note: in #fedora-meeting-1), acting as a blocker review meeting. Accepted as a blocker due to violation of criterion "All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work". Ray, can you please look a little closer into why some people are seeing no PM options in gdm? As 'log out then shut down from gdm' is the 'official way' to shut down a GNOME 3 system, this is a bit of a problem.

we also have a problem with the fix for this - it's submitted as part of the huge GNOME 3.1.92 update, and we're not going to take that into beta (probably...), so we somehow need gdm to be split out. might need releng help with that.
Comment 13 Daniel Belton 2011-09-21 23:34:07 EDT
This is also a duplicate of Bug 736793 that I reported on Sept 8 that got closed by Matthias Clasen with a link to an upstream bug that had nothing to do with this bug. 

https://bugzilla.redhat.com/show_bug.cgi?id=736793
Comment 14 Adam Williamson 2011-09-21 23:39:13 EDT
Not entirely. This bug is about the shutdown option *not working*. Your bug is about it not being visible. A bit of your bug has crept into this bug, but it's not really the focus.
Comment 15 Kamil Páral 2011-09-22 04:18:21 EDT
I have reopened bug 736793, let's use it for discussing the lost reboot/poweroff options and keep this bug to its original description.
Comment 16 Adam Williamson 2011-09-22 20:13:53 EDT
so there's a bit of a problem with taking 3.1.92 to fix this: as mentioned in 736793, my initial testing suggests it doesn't show PM options in Shell mode, without the rest of the 3.1.92 update (I'm guessing Shell needs to be updated too, but I haven't tested exactly what package makes it work).

Ray, would it be possible to backport just the fix for this issue to 3.1.90 for Beta purposes? It would really be tricky to take the whole 3.1.92 update in Beta at this point. thanks!
Comment 17 Kamil Páral 2011-09-23 02:56:17 EDT
I have to point out once again that I didn't see poweroff/reboot options in gdm running in Shell mode even with 3.1.90. I can definitely try to do a new clean install of Beta RC1 if required. Mine current installation is an upgrade from TC1 or something.
Comment 18 Mads Kiilerich 2011-09-23 09:43:05 EDT
FWIW, I can confirm that upgrading a 2 days old updates-testing system to gdm-3.1.92-1.fc16.x86_64 alone also didn't make shutdown appear in gdm for me.

When I also updated to gjs-1.29.18-1.fc16.x86_64 and mutter-3.1.92-1.fc16.x86_64 with dependencies (such as clutter-1.8.0-1.fc16.x86_64 cogl-1.8.0-1.fc16.x86_64 gnome-shell-3.1.92-1.fc16.x86_64) the power options showed up as I expected.
Comment 19 John Dulaney 2011-09-23 12:50:26 EDT
I have confirmed Mads' update sequence to get the shutdown option.
Comment 20 Adam Williamson 2011-09-23 13:04:02 EDT
the desktop team tells us that it's gnome-shell-3.1.92 which you need to get the buttons: gnome-shell is actually now responsible for that screen itself.

given the amount of change necessary to fix this - either a messy backport, or taking the whole of gnome 3.1.92 into beta - we may have to simply declare that it works 'well enough' (as in you can reboot from the desktop with the hold-down-alt-key dodge, or switch to a VT and reboot from there).
Comment 21 Tim Flink 2011-09-23 14:36:37 EDT
Discussed in the 2011-09-23 blocker review meeting. Assuming that it can be pulled in by itself, pulling in gdm-3.1.92 alone sounds like a reasonable solution to fix this particular bug even though it won't touch 736793.

However, a bit more testing is needed before going forward with this for beta final.
Comment 22 Tim Flink 2011-09-30 11:17:48 EDT
I've tested this with both gnome-shell and gnome-panel using beta RC4 - the shutdown option works with gnome-panel and doesn't exist for gnome-shell.

While somewhat sub-optimal, this is the fix that we were expecting for beta. The power menu should return to the gdm greeter with updates to gnome-shell.
Comment 23 Adam Williamson 2011-10-03 12:02:55 EDT
as there's no update to push here, exactly, and we've verified the fix in rc4, we can close this one. we can't push the whole gnome 3.1.92 into the stable package set, it'll just have to wait for the unfreeze.

Note You need to log in before you can comment on or make changes to this bug.