Bug 739828 - filtering screen shows loop devices
Summary: filtering screen shows loop devices
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 16
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker, AcceptedNTH
Keywords:
: 743858 (view as bug list)
Depends On:
Blocks: ZedoraTracker F16-accepted, F16FinalFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-09-20 07:35 UTC by Jan Stodola
Modified: 2014-09-30 23:40 UTC (History)
9 users (show)

Fixed In Version: anaconda-16.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-03 01:46:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot with loop devices (83.58 KB, image/png)
2011-09-20 07:35 UTC, Jan Stodola
no flags Details

Description Jan Stodola 2011-09-20 07:35:52 UTC
Created attachment 523963 [details]
screenshot with loop devices

Description of problem:
When running graphical (vnc) installation of F16 on s390x, filtering UI shows loop devices (loop0 - loop2) in addition to DASD drives. See attached screenshot.

These loop devices are:
-bash-4.2# losetup -a
/dev/loop0: [0001]:5674 (/squashfs.img)
/dev/loop1: [0700]:3 (/run/initramfs/squashfs/LiveOS/rootfs.img)
/dev/loop2: [0001]:6012 (/overlay)

Version-Release number of selected component (if applicable):
anaconda-16.17

How reproducible:
always

Steps to Reproduce:
1. start the installation in vnc mode
2. proceed to "Specialized Storage Devices"
3. inspect "Basic Devices" tab
  
Actual results:
loop devices are available to be used for the installation

Expected results:
loop devices are not shown

Comment 2 Ales Kozumplik 2011-09-23 11:51:53 UTC
I can see this on x86_64, both alpha and beta-tc2.

Comment 3 Ales Kozumplik 2011-09-23 12:33:04 UTC
David, I can reproduce this easily so in case you haven't started working on this yet you can assign it to me.

Comment 5 Tim Flink 2011-10-03 16:50:53 UTC
Discussed in the 2011-09-30 blocker bug review meeting. Rejected as a blocker bug for Fedora 16 final because it doesn't hit any release criteria, only shows up with advanced storage devices and doesn't prevent installation.

However, it can't be fixed post-release and it does look bad to have non-usable devices in the installer. Accepted as NTH for Fedora 16 final.

Comment 6 Ales Kozumplik 2011-10-04 08:40:34 UTC
Fixed by 9936f7037d4fbcb1401e5b5e0c46043d80b8b43f (2f133582caf371d4a21ef15d8b73093ac6d65e2d on master).

Comment 7 Martin Gracik 2011-10-06 11:32:57 UTC
*** Bug 743858 has been marked as a duplicate of this bug. ***

Comment 8 Dan Horák 2011-10-21 12:26:06 UTC
I can confirm that loop devices are not shown with anaconda-16.22

Comment 9 Adam Williamson 2011-11-03 01:46:47 UTC
let's close this, then, as anaconda is well past 16.22.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.