Bug 740391 - Could not start virtual network 'default'
Summary: Could not start virtual network 'default'
Keywords:
Status: CLOSED DUPLICATE of bug 735414
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-21 20:58 UTC by Martin Kho
Modified: 2011-09-26 14:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 14:53:17 UTC


Attachments (Terms of Use)
virt-manager.log (10.40 KB, text/x-log)
2011-09-21 20:58 UTC, Martin Kho
no flags Details

Description Martin Kho 2011-09-21 20:58:53 UTC
Created attachment 524275 [details]
virt-manager.log

Description of problem:

Could not start virtual network 'default': internal error Child process (/usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/default.pid --conf-file= --except-interface lo --listen-address 192.168.122.1 --dhcp-range 192.168.122.2,192.168.122.254 --dhcp-leasefile=/var/lib/libvirt/dnsmasq/default.leases --dhcp-lease-max=253 --dhcp-no-override) status unexpected: exit status 2

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/uihelpers.py", line 631, in validate_network
    virnet.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 1452, in create
    if ret == -1: raise libvirtError ('virNetworkCreate() failed', net=self)
libvirtError: internal error Child process (/usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/default.pid --conf-file= --except-interface lo --listen-address 192.168.122.1 --dhcp-range 192.168.122.2,192.168.122.254 --dhcp-leasefile=/var/lib/libvirt/dnsmasq/default.leases --dhcp-lease-max=253 --dhcp-no-override) status unexpected: exit status 2

Version-Release number of selected component (if applicable):
* virt-manager-0.9.0-5.fc16.noarch
* dnsmasq-2.58-2.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add new vm (e.g. Fedora 16 Beta rc1)
2. At step 5 of 5 a message appears that the network can not be started
3. Press Finish (the above message appears in a message box)
  
Actual results:
new VM can not be created

Expected results:
new VM is created.

Additional info:
I've added the version of dnsmasq because it can also be the culprit (internal error Child process).

Comment 1 Martin Kho 2011-09-21 21:19:50 UTC
Hi,

Should have searched for dnsmasq bugs first ;-( See [1]. Please close this report.


Thanks,

Martin Kho

[1] https://bugzilla.redhat.com/show_bug.cgi?id=735414

Comment 2 Cole Robinson 2011-09-26 14:53:17 UTC

*** This bug has been marked as a duplicate of bug 735414 ***


Note You need to log in before you can comment on or make changes to this bug.