Bug 74041 - metacity should own more directories
Summary: metacity should own more directories
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-09-13 20:34 UTC by Enrico Scholz
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-10 21:33:05 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 20:34:28 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing the package because orphaned
directories will remaining.


| $ rpm -qf /usr/share/gnome/wm-properties /usr/share/gnome/wm-properties/metacity.desktop
| file /usr/share/gnome/wm-properties is not owned by any package
| metacity-2.4.0.91-2

(Please visit the given URL for a complete list of affected directories)


Version-Release number of selected component (if applicable):

metacity-2.4.0.91-2


How Reproducible: 100%


Steps to Reproduce:
0. make a minimal installation
1. umask 077
2. make sure that metacity is uninstalled completely
   (rm -rf /usr/share/gnome/wm-properties)
3. rpm -U metacity-2.4.0.91-2.i386.rpm
4. ls -l /usr/share/gnome/wm-properties
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e metacity-2.4.0.91-2


Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 22:27 /usr/share/gnome/wm-properties
* files can not be found/read at 5 and
* /usr/share/gnome/wm-properties still exists after 6.

Comment 1 Dan Williams 2003-09-10 21:33:05 UTC
wm-properties is no longer in metacity package.


Note You need to log in before you can comment on or make changes to this bug.