Bug 74070 - Problem during Installation - Crash/Bug Report
Problem during Installation - Crash/Bug Report
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 74146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-14 12:33 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-17 16:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (70.87 KB, text/plain)
2002-09-15 19:26 EDT, Robert J. Drejer
no flags Details

  None (edit)
Description Need Real Name 2002-09-14 12:33:53 EDT
Description of Problem:


Version-Release number of selected component (if applicable):
During the installation - usually when it comes near the end of the second CD - 
I get the following:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 611, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 244, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 86, in getFilename
    isys.umount("/mnt/source")
  File "/usr/lib/anaconda/isys.py", line 171, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')


How Reproducible:
Install from ISO CD's


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
I have used two different sets of CD's - different ISO's - same result.

I have tried this on two computers consisting of identical hardware..

New hardware with no OS..

Celeron 1.4GHZ
80GB EIDE HD
CDRW
AOPEN Micro AXT - integrated video/lan/sound
Comment 1 Robert J. Drejer 2002-09-15 19:26:20 EDT
Created attachment 915028 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 2 Michael Fulbright 2002-09-16 13:15:18 EDT
Your CD appears to be bad.

You can test it following these instructions:

 http://people.redhat.com/~msf/mediacheck.html
Comment 3 Robert J. Drejer 2002-09-16 17:52:13 EDT
As advised, I used linux mediacheck to test the media on all CD's.  The five 
disks for installation and source code passed.  The program was unable to check 
the other 3 disks stating "unable to read the disk checksum from the primary 
volume descriptor".  I then attempted to install the program again with the 
same final result.  I gets to the 50% installed point and stops with the 
message reported by me yesterday.

At one point in the installation I get the message: "The 
file /mnt/source/RedHat/RPMS/psmisc-20.2 i386.rpm cannot be opened.  This is 
due to a missing file, a bad package, or bad media.  Press <return> to try 
again".  I pressed return and it continued to install for a while.
Comment 4 Need Real Name 2002-09-17 08:19:26 EDT
All 3 installation CDs pass. I have even tried the installation with a second 
set of CDs created from different ISO images. As a hardware test, I 
successfully installed Engarde Linux on the machine. The Bug Report I listed at 
the top of the thread doesnt seem to indicate a media failure.  It seems to be 
an issue of dismounting a device. I have replaced the CDROM drive twice and I 
still get the same result. (note that I have also attempted the installation on 
two new computers consisting of the identical hardware. (new hardware)
Comment 5 Need Real Name 2002-09-17 13:06:47 EDT
I dont get a message in the bug trace that says it cant open a file and I dont 
get an option to continue "try again". It simpley gets to the end on the 
install (last package) and the Anaconda crash/bug appears telling me to copy it 
to a diskette and report it to Bugzilla. If I just click OK, it reboots and 
locks up.
Comment 6 Robert J. Drejer 2002-09-17 16:22:32 EDT
*** Bug 74146 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2002-09-20 17:15:12 EDT
If you have purchased this from Red Hat you should contact Red Hat Customer
service and let them know your media is not working.

This error is related to read errors occurring during installation. You may have
better luck trying a hard drive based install if this problem continues.

Note You need to log in before you can comment on or make changes to this bug.