Bug 74073 - glibc cause a crash when accesing my bank acount with netscape java.
glibc cause a crash when accesing my bank acount with netscape java.
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 75221 75314 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-14 14:32 EDT by Knut J BJuland
Modified: 2016-11-24 10:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 16:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2002-09-14 14:32:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020830

Description of problem:
I get a when (gdb) Program received signal SIGSEGV, Segmentation fault.
0x404a9ee9 in _nss_dns_gethostbyname2_r () from /lib/libnss_dns.so.2
(gdb) Quit(gdb) when accesing by acount through netscape java

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start netscape 4.79 and load
https://dnb.no/dnblogin/index.jhtml;jsessionid=FFHJC1NLAH4A1QFIAFCCFE4AVAAUGIWD?null&_requestid=187297&_requestid=43119
2. click on  "Betaling og kontohold" and watch netscape sgment fault when the
java applet is starting to load.
3.
	

Actual Results:  Netscape should not crash

Expected Results:  Netscape crash

Additional info:

I know that Redhat have chosen to include netscape, but Mozilla java is not
supported by my bank. Netscape 4.79 java is supported.
Comment 1 Jakub Jelinek 2002-10-18 16:02:12 EDT
Can you please try ftp://people.redhat.com/jakub/glibc/2.3.1-2/
?
Comment 2 Knut J BJuland 2002-10-18 16:39:28 EDT
It work with glibc 2.3.1-2 mark this bug as resolve and bug also  whici is a
duplicat https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75314. 
Comment 3 Jakub Jelinek 2002-10-18 16:43:40 EDT
*** Bug 75314 has been marked as a duplicate of this bug. ***
Comment 4 Knut J BJuland 2002-10-19 04:15:53 EDT
This bug does not affect me any longer
Comment 5 R.K.Aa. 2002-10-20 12:28:06 EDT
This bug is a disaster. People can no longer user their java-based netbanks. I
got a mail from a complete stranger who had already downgraded to RH7.3 again.
He thanked me for the pointer to this bug, with the link to a glibc version that
acclaimedly works.

Other instances of this bug are bug 75334 and bug 75221. notting@redhat.com
keeps resolving this grim crasher as "NOTABUG". Shouldn't an errata be made
instead? NOTHING in the release-notes tell about this disaster. It is only
mentioned that Netscape is no longer included. 

Is my Java based banking on RedHat now dependant on one private developer's
glibc fix? Or are users recommended to change bank?
Comment 6 Knut J BJuland 2002-10-20 14:07:55 EDT
I can access my nettbank with the glibc fix from
ftp://people.redhat.com/jakub/glibc/2.3.1-2/. I think Redhat should add thesse
new glibc 2.3.1 as errata for Redhat Linux 8.0
Comment 7 Jakub Jelinek 2002-10-20 14:30:51 EDT
We are of course planning to release this as errata for 8.0 after it passes through QA.
Comment 8 Bill Nottingham 2002-10-21 00:25:23 EDT
*** Bug 75221 has been marked as a duplicate of this bug. ***
Comment 9 R.K.Aa. 2003-03-21 14:35:44 EST
On Oct. 20th 2002, Jakub Jelinek wrote:
"We are of course planning to release this as errata for 8.0 after it passes
through QA."

Now a new errata glibc is out. Can i safely upgrade from your
ftp://people.redhat.com/jakub/glibc/2.3.1-2/ to the errata, and expect that java
in Netscape 4.79 still works?

Note You need to log in before you can comment on or make changes to this bug.