Bug 740748 - Subscribe button in Subscription Assistant should be disabled when no subscription is selected
Subscribe button in Subscription Assistant should be disabled when no subscri...
Status: CLOSED DUPLICATE of bug 740831
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-23 04:20 EDT by yu zheng
Modified: 2015-05-14 11:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-25 22:53:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Subscribe button in Subscription Assistant isn't disabled when no subscription is selected (151.82 KB, image/png)
2011-09-23 04:22 EDT, yu zheng
no flags Details

  None (edit)
Description yu zheng 2011-09-23 04:20:56 EDT
Description of problem:
After registering, subscribe button in Subscription Assistant can still be clicked when no subscription is selected.

Version-Release number of selected component (if applicable):
subscription-manager-0.96.11-1.el6.x86_64
python-rhsm-0.96.12-1.el6.noarch
candlepin (stage env)

How reproducible:
Always

Steps to Reproduce:
1.register to stage using stage_test_2/redhat
2.# subscription-manager-gui
3.click "Update Certificates" and the Subscription Assistant dialog pops up.
4.check product "Red Hat Enterprise Linux 6 Server" and select its available subscription, then click subscribe button.
5.click subscribe button again.

Actual results:
Subscribe button can be clicked even if no subscription is selected.
The terminal prints error message as follows.
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/subscription_assistant.py", line 554, in subscribe_button_clicked
    pool_id = model.get_value(tree_iter, self.subscriptions_store['pool_id'])
TypeError: iter must be a GtkTreeIter

Expected results:
Subscribe button should be disabled.

Additional info:
N/A
Comment 1 yu zheng 2011-09-23 04:22:52 EDT
Created attachment 524551 [details]
Subscribe button in Subscription Assistant isn't disabled when no subscription is selected
Comment 2 Keqin Hong 2011-09-25 22:53:11 EDT

*** This bug has been marked as a duplicate of bug 740831 ***

Note You need to log in before you can comment on or make changes to this bug.