Bug 740831 - TypeError: iter must be a GtkTreeIter
Summary: TypeError: iter must be a GtkTreeIter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.2
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Adrian Likins
QA Contact: IDM QE LIST
URL:
Whiteboard: abrt_hash:312c4231a2eba99db18d0ccce23...
: 740748 (view as bug list)
Depends On:
Blocks: rhsm-rhel62 691780 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-23 13:51 UTC by Alexander Todorov
Modified: 2011-12-06 17:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:24:40 UTC


Attachments (Terms of Use)
File: firstboot-tb-Jhl_bF (688.69 KB, text/plain)
2011-09-23 13:51 UTC, Alexander Todorov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description Alexander Todorov 2011-09-23 13:51:45 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: firstboot
kernel:         2.6.32-201.el6.x86_64
reason:         TypeError: iter must be a GtkTreeIter
time:           Fri Sep 23 09:51:05 2011

firstboot-tb-Jhl_bF: Binary file, 705219 bytes

description:
:The following was filed automatically by firstboot:
:firstboot 1.110.11 exception report
:Traceback (most recent call last):
:  File "/usr/share/rhsm/subscription_manager/gui/subscription_assistant.py", line 554, in subscribe_button_clicked
:    pool_id = model.get_value(tree_iter, self.subscriptions_store['pool_id'])
:TypeError: iter must be a GtkTreeIter

Comment 1 Alexander Todorov 2011-09-23 13:51:49 UTC
Created attachment 524621 [details]
File: firstboot-tb-Jhl_bF

Comment 2 Alexander Todorov 2011-09-23 13:54:35 UTC
I'm not exactly sure how I triggered this error. 

The system has been previously subscribed. Then I unsubscribed and unregistered it and deleted redhat.repo. 

After reboot into firstboot I selected to subscribe to Red Hat Employee subscription. Instead of subscribing in the list of available subscriptions appeared a second entry with the same name. Both entries were selected. When clicking on the subscribe button again I hit this error.

Comment 3 Alexander Todorov 2011-09-23 14:22:58 UTC
Here are more detailed steps to reproduce:

1) In firstboot register the system
2) Click on update certificate
3) Select product RHEL Workstation
4) Select subscription Red Hat Employee subscription
5) click Subscribe

6) there's a quick progress dialog after which the Subscribe button is not disabled. 
7) Click again on Subscribe.

You hit the bug.

Comment 4 Devan Goodwin 2011-09-23 16:07:47 UTC
Can be reproduced outside of firstboot with just normal GUI usage.

- Update Certificates
- Select a product, and then a subscription to provide it below.
- Bind takes place, but Subscription button remains enabled. (at this point nothing is selected in the Subscriptions pane)
- Hit the button, error takes place.

Subscription button is probably just not getting disabled properly.

Comment 5 Adrian Likins 2011-09-23 18:48:58 UTC
commit 15fc9d21dbf1816d3f29c609b9ff92504874d44b
Author: Adrian Likins <alikins@redhat.com>
Date:   Fri Sep 23 13:19:55 2011 -0400

    740831: set subscribe button insensitive if nothing is selected
    
    Subscribe was still sensitive with nothing to subscribe to
    causing errors trying to find null TreeIter in the treeview

Comment 7 Keqin Hong 2011-09-26 02:53:11 UTC
*** Bug 740748 has been marked as a duplicate of this bug. ***

Comment 8 J.C. Molet 2011-09-27 18:55:17 UTC
The commit in comment 5 works.  I've tested this in both the subscription assistant and in the "all subscriptions" tab.  After subscribing the "Showing" state is removed from the button - making it greyed out and unclickable.

moving to VERIFIED.

Tested against:

subscription-manager-gnome-0.96.11-1.git.11.4ea289b.el6.x86_64

Comment 9 errata-xmlrpc 2011-12-06 17:24:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.