This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 740877 - autosubscribe output is reporting the product certs' version instead of status
autosubscribe output is reporting the product certs' version instead of status
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Adrian Likins
IDM QE LIST
: Regression
: 740727 (view as bug list)
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-23 11:44 EDT by John Sefler
Modified: 2011-12-06 12:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:24:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-09-23 11:44:50 EDT
Description of problem:
When autosubscribing, the status of the installed products is echoed to stdout.  I suspect a side affect of the new design change from bug 736424 to have caused the following bug behavior...

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin --autosubscribe
The system has been registered with id: c06d6b7e-f143-4f95-adfe-de28adb48f78 
Installed Product Current Status:

ProductName:         	Awesome OS for ia64 Bits 
Status:               	3.11                     


ProductName:         	Stackable with Awesome OS for x86_64 Bits
Status:               	3.11                     


ProductName:         	Awesome OS Developer Basic
Status:               	1.0      

^^^^^^                  ^^^
These status fields are reporting the product cert's version instead of "Subscribed", "Not Subscribed", "Partially Subscribed"



Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.11-1.el6.x86_64
Comment 2 Adrian Likins 2011-09-26 13:49:02 EDT
commit 4ea289b807c59ac9e73a056b92c03a0f7c2fed59
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Sep 26 12:47:52 2011 -0400

    740877: autosubscribe output was showing ver instead of status
Comment 4 J.C. Molet 2011-09-26 14:28:19 EDT
This works now:


[root@jmolet-vm0 ~]# subscription-manager register --username=testuser1 --password=password --org=admin --autosubscribe 
The system has been registered with id: 2616c323-6200-452b-b8fc-61d81b3a4af3 
Installed Product Current Status:

ProductName:         	Awesome OS for S390 Bits 
Status:               	Not Subscribed           


ProductName:         	Stackable with Awesome OS for x86_64 Bits
Status:               	Not Subscribed           


ProductName:         	Red Hat Linux 4.0        
Status:               	Not Subscribed

etc etc...


Tested against: 
subscription-manager-0.96.11-1.git.11.4ea289b.el6.x86_64

marking VERIFIED.
Comment 5 Keqin Hong 2011-09-26 22:59:09 EDT
*** Bug 740727 has been marked as a duplicate of this bug. ***
Comment 6 errata-xmlrpc 2011-12-06 12:24:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.