Bug 740911 - Document shifted by an inch at printing time.
Summary: Document shifted by an inch at printing time.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 18:34 UTC by Andrew McNabb
Modified: 2012-08-07 19:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 19:09:00 UTC


Attachments (Terms of Use)
troubleshoot.txt (341.81 KB, text/plain)
2011-09-23 18:34 UTC, Andrew McNabb
no flags Details

Description Andrew McNabb 2011-09-23 18:34:41 UTC
Created attachment 524672 [details]
troubleshoot.txt

Description of problem:

When printing a letter sized PDF onto letter paper, the page was shifted about an inch to the right (the printed paper has a huge left margin and part of the text on the right is cut off). I'm providing a URL to the PDF in the "Steps to Reproduce" section below. If I print to a file (instead of to the printer), the output file looks exactly like the original PDF.

So far, I have only seen this problem on this particular document.


Version-Release number of selected component (if applicable):

cups-1.4.8-2.fc15.x86_64


How reproducible:

every time


Steps to Reproduce:
1. Load http://aml.cs.byu.edu/~amcnabb/EVCO_a_00025-nup.pdf in evince.
2. Print.

  
Actual results:

Page should appear as on the screen.


Expected results:

Page is shifted by about an inch to the right.


Additional info:

The printer is an HP LaserJet P4015.

I am attaching the output from the Troubleshooting wizard.

Comment 1 Tim Waugh 2011-09-27 14:23:51 UTC
If you print the first page of the document like this, do you also see the problem?:

lp -d printer -P 1-2 -o sides=two-sided-short-edge EVCO_a_00025-nup.pdf

Comment 2 Andrew McNabb 2011-09-27 16:35:51 UTC
Hmm... now it's hanging in the queue with Status "Processing" for 20 minutes at a time. :(  And this is happening when I print in Evince or with the command in comment 1. :(

Restarting cups didn't work, so unless you have a great tip about how to get it unstuck, I'll plan on trying again later today or tomorrow and hoping that it works then.

Comment 3 Andrew McNabb 2011-09-27 18:56:22 UTC
If I print just the first page, then instead of hanging, I get a dialog saying, "There was a problem processing document `EVCO_a_00025-nup.pdf' (job 211)."  At localhost:631, I see a message stating that the status is: 'stopped "/usr/lib/cups/filter/gstoraster failed"'.  CUPS really doesn't seem to like this file. :)

Comment 4 Tim Waugh 2011-09-28 08:33:24 UTC
OK, we'll come back to that issue later.

Could you try just printing it "as normal" from the command line?

lp -d printer -o sides=two-sided-short-edge EVCO_a_00025-nup.pdf

Comment 5 Andrew McNabb 2011-09-28 16:43:29 UTC
This is so weird. The lp command in comment #4 is also hanging (and I tried it on another Fedora 15 machine to make sure there's nothing weird with mine). I've also tried printing using the lp commands from both comment #1 and comment #4 on a Fedora 14 machine, and the jobs are both hanging.

Comment 6 Andrew McNabb 2011-09-28 20:27:33 UTC
I've now noticed a margin problem with other documents, so the margin shift problem might be a duplicate of bug #738089. Unfortunately, I still have no idea why this particular document is hanging in the queue.

Comment 7 Tim Waugh 2011-09-29 08:41:29 UTC
The "lp" command hanging and the job hanging in the queue are two different things.  Does the "lp" command finish?  If not, there is a communication problem between lp and the scheduler.

Comment 8 Andrew McNabb 2011-09-29 16:17:13 UTC
Sorry, I must have misspoken. The lp command completes, but the job hangs in the queue.

Comment 9 Fedora End Of Life 2012-08-07 19:09:02 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.