Bug 74115 - wrong message info displayed
wrong message info displayed
Status: CLOSED DUPLICATE of bug 91232
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-09-16 08:59 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
pine bug (87.42 KB, image/png)
2002-09-17 07:26 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-09-16 08:59:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
The message info (date, subject, from) is incorrectly displayed for some
messages in the folder list. Just the date field is visible.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Receive some mails

Additional info:
Comment 1 Mike A. Harris 2002-09-17 00:28:20 EDT
Please attach a screenshot illustrating the problem you're seeing.
Comment 2 Need Real Name 2002-09-17 07:26:14 EDT
Created attachment 76366 [details]
pine bug
Comment 3 Need Real Name 2002-09-17 07:28:26 EDT
Dont know if it is a pine related bug, I got some strange behavior in my text
apps , the kernel configuration menu (make menuconfig) looks terrible too and
some spanish chars (a q) are missing in the character set (text mode only).
Comment 4 Mike A. Harris 2002-11-12 22:14:31 EST
The problem here, is that PINE is not UTF-8 compatible.  This is not a bug,
but rather is just a feature lacking in pine and a lot of other text mode
apps like mutt, screen, mc, etc.

RHL 8.0 uses UTF-8 by default, and so apps that aren't UTF-8 clean will
not display correctly.  The solution is to change the LANG variable
while running the application.

For example, if you use en_US.UTF-8 by default in RHL 8.0, you would do:

LANG=en_US pine

It might be possible for me to write a pine wrapper script and rename the
pine binary to pine-bin or something, and have it test LANG for a .UTF-8
component, and strip it off if present, then invoke pine with it's own
LANG setting.  I'm not sure if that would cause other problems or not
Comment 5 Mike A. Harris 2002-11-12 22:28:44 EST
You can try this as root if you want:

mv /usr/bin/pine /usr/bin/pine-bin

cat <<-EOF > /usr/bin/pine
# Remove .UTF-8 .UTF8 .utf-8 .utf8 from $LANG for pine as it
# does not understand unicode currently.
LANG=$(echo $LANG | sed -e 's#\.UTF.\{0,1\}8$##i') pine-bin

Does this work for you ok?
Comment 6 Mike A. Harris 2003-01-11 21:55:45 EST
Comment 7 Mike A. Harris 2003-01-24 16:24:22 EST
Deferring issue for future pine release to reinvestigate
Comment 8 Mike A. Harris 2003-05-13 05:16:19 EDT
This is indeed UTF-8 related, and not a bug.  My advice about UTF-8 above
should work as a workaround.  Pine still does not support unicode in it's
latest 4.5x releases, and it doesn't appear the pine team will be adding
unicode support any time soon, so this will likely remain a misfeature
of pine for quite some time.

Pine has been removed from the developmental version of Red Hat Linux, and
will no longer be a part of Red Hat Linux.  I'm closing this bug as NOTABUG
as it is really just lack of unicode, which is a missing feature rather than
a bug.
Comment 9 Mike A. Harris 2003-05-20 04:31:43 EDT

*** This bug has been marked as a duplicate of 91232 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:49:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.