Bug 91232 - (pineutf8) Pine does not work properly in UTF-8 locales
Pine does not work properly in UTF-8 locales
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
: 70518 74115 77197 90661 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-20 04:27 EDT by Mike A. Harris
Modified: 2007-04-18 12:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-20 04:30:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2003-05-20 04:28:00 EDT
Red Hat Linux 8.0 and 9 both use UTF-8 unicode locales by default, however
a number of text mode applications such as pine, pico, mutt, mc, and numerous
others display various types of console corruption when ran under UTF-8
locales.  Some of the possible problems that one might encounter include:

- Line drawing characters disappear, are replaced with boxes, or random junk,
  or some odd looking character.

- 8bit non-ASCII characters used in European and other languages, such as the
  German umlaut, French accented characters, and most other foreign accented
  characters will look like multiple random characters globbed together.

- The application's display may do odd things with the cursor

- The display may become heavily corrupted, or scroll.

- Characters may disappear off the screen completely.  This occurs in pine's
  message folder index screen and elsewhere as well.

Other types of screen corruption and odd behaviour may result as well.  Almost
all reported cases of these types of problems are not application bugs, but are
rather just that the application does not support unicode and will not work
properly in UTF-8 locales due to lack of support of UTF-8.  These applications
will only work natively in UTF-8 when (and if) their upstream project
maintainers develop proper UTF-8 support for the given application(s).

Due to the nature of adding such support, Red Hat will not generally develop
the required support for such applicaitons ourselves, unless we are the
actual upstream maintainers of the given software.  In general, the upstream
project will have to add support themselves for UTF-8, prior to it being
supported in Red Hat Linux.

You can generally work around these unfortunate and somewhat inconvenient
limitations usually by executing the application in a non-UTF-8 locale by doing
something like:

LANG=en_US pine

You may also have to configure your terminal emulator software such as
gnome-term, etc. to use an ISO-8859 based locale for it to work properly.

Another alternative is to switch off UTF-8 systemwide by editing the
/etc/sysconfig/i18n file and removing all occurances of ".UTF-8" then
rebooting the system.

The above examples should work for most software affected by lack of
proper unicode support.

As an added note, pine is now removed from our developmental tree (rawhide),
and will no longer be included in future versions of Red Hat Linux, so it
is unlikely it will ever support Unicode in the distribution.

This bug report is intended for use as a generic bug tracker master duplicate.
Comment 1 Mike A. Harris 2003-05-20 04:30:04 EDT
Closing bug report as NOTABUG, as this is a lack of a feature in pine
and similar apps, rather than a bug.  Users are encouraged to contact the
upstream project authors to request and/or help them to develop UTF-8 support.

Comment 2 Mike A. Harris 2003-05-20 04:31:18 EDT
*** Bug 70518 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2003-05-20 04:31:46 EDT
*** Bug 74115 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2003-05-20 04:32:26 EDT
*** Bug 77197 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2003-05-20 04:34:08 EDT
*** Bug 90661 has been marked as a duplicate of this bug. ***
Comment 6 Jungshik Shin 2003-05-20 07:41:30 EDT
Just FYI, mutt works rather well even for CJK under UTF-8 locale. It's the best
text-mode email client in terms of I18N. 

For others on CC interested in Pine with better UTF-8 support and I18N, 
Bernhard Kaindl (bernhard dot kaindl at gmx  dot de) has updated and refined my
patch for Pine 4.33(posted to linux-utf8 mailing list and c.m.pine) to make it
work with Pine 4.5x and more importantly to make  the mail header editing work
better under UTF-8 terminal.  Those interested in his patch may contact him
directly. Judging from my email exchnages with one of Pine team members last
year, it's not likely that they will accept any patch using iconv(3). Why? Don't
ask me ;-).  (I tried really hard to persuade him that iconv(3) is the way to
go....)

Note You need to log in before you can comment on or make changes to this bug.