Bug 741309 (CVE-2011-3825) - CVE-2011-3825 php-ZendFramework: Installation path disclosure via a direct request to a Validate.php file
Summary: CVE-2011-3825 php-ZendFramework: Installation path disclosure via a direct re...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2011-3825
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 741310 741311
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 14:41 UTC by Jan Lieskovsky
Modified: 2019-09-29 12:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-24 03:53:36 UTC


Attachments (Terms of Use)

Description Jan Lieskovsky 2011-09-26 14:41:52 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2011-3825 to
the following vulnerability:

Zend Framework 1.11.3 in Zend Server CE 5.1.0 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by Validate.php and certain other files.

References:
[1] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3825
[2] http://www.openwall.com/lists/oss-security/2011/06/27/6
[3] http://code.google.com/p/inspathx/source/browse/trunk/paths_vuln/%21_README
[4] http://code.google.com/p/inspathx/source/browse/trunk/paths_vuln/Zend

Comment 1 Jan Lieskovsky 2011-09-26 14:45:10 UTC
Created php-ZendFramework tracking bugs for this issue

Affects: fedora-all [bug 741310]
Affects: epel-6 [bug 741311]


Note You need to log in before you can comment on or make changes to this bug.