Bug 741368 - SELinux is preventing /bin/systemctl from 'search' accesses on the directory 1.
Summary: SELinux is preventing /bin/systemctl from 'search' accesses on the directory 1.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2542bc170d666dbd429baa2176c...
: 741367 741369 741370 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 17:10 UTC by James Cape
Modified: 2011-10-09 19:36 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.10.0-38.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-09 19:36:39 UTC


Attachments (Terms of Use)

Description James Cape 2011-09-26 17:10:27 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-0.rc6.git0.3.fc16.x86_64
reason:         SELinux is preventing /bin/systemctl from 'search' accesses on the directory 1.
time:           Mon Sep 26 12:10:20 2011

description:
:SELinux is preventing /bin/systemctl from 'search' accesses on the directory 1.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemctl should be allowed search access on the 1 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemctl /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewallgui_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:init_t:s0
:Target Objects                1 [ dir ]
:Source                        systemctl
:Source Path                   /bin/systemctl
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-units-35-1.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-32.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux orwell.ignore-your.tv
:                              3.1.0-0.rc6.git0.3.fc16.x86_64 #1 SMP Fri Sep 16
:                              12:26:22 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 26 Sep 2011 12:09:41 PM CDT
:Last Seen                     Mon 26 Sep 2011 12:09:41 PM CDT
:Local ID                      ee59b2fe-8c0f-4d84-9304-8772396e1d87
:
:Raw Audit Messages
:type=AVC msg=audit(1317056981.884:194): avc:  denied  { search } for  pid=6510 comm="systemctl" name="1" dev=proc ino=8207 scontext=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1317056981.884:194): avc:  denied  { read } for  pid=6510 comm="systemctl" name="root" dev=proc ino=1662 scontext=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=lnk_file
:
:
:type=AVC msg=audit(1317056981.884:194): avc:  denied  { read } for  pid=6510 comm="systemctl" scontext=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1317056981.884:194): arch=x86_64 syscall=stat success=yes exit=0 a0=4259e2 a1=7fffe27e1f60 a2=7fffe27e1f60 a3=0 items=0 ppid=6509 pid=6510 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemctl exe=/bin/systemctl subj=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 key=(null)
:
:Hash: systemctl,firewallgui_t,init_t,dir,search
:
:audit2allow
:
:#============= firewallgui_t ==============
:allow firewallgui_t init_t:dir search;
:allow firewallgui_t init_t:file read;
:allow firewallgui_t init_t:lnk_file read;
:
:audit2allow -R
:
:#============= firewallgui_t ==============
:allow firewallgui_t init_t:dir search;
:allow firewallgui_t init_t:file read;
:allow firewallgui_t init_t:lnk_file read;
:

Comment 1 Daniel Walsh 2011-09-26 17:49:44 UTC
*** Bug 741367 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2011-09-26 17:54:57 UTC
*** Bug 741369 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2011-09-26 17:55:13 UTC
*** Bug 741370 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2011-09-26 18:01:39 UTC
Fixed in selinux-policy-3.10.0-35.fc16

Comment 5 Fedora Update System 2011-10-04 11:17:36 UTC
selinux-policy-3.10.0-36.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-36.fc16

Comment 6 Fedora Update System 2011-10-04 20:50:27 UTC
Package selinux-policy-3.10.0-36.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-36.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-36.fc16
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-10-09 19:36:39 UTC
selinux-policy-3.10.0-38.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.