Bug 741370 - SELinux is preventing /bin/bash from 'getattr' accesses on the file /lib/systemd/system/iptables.service.
Summary: SELinux is preventing /bin/bash from 'getattr' accesses on the file /lib/syst...
Keywords:
Status: CLOSED DUPLICATE of bug 741368
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:10ea02da8215cef2656908bab74...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 17:11 UTC by James Cape
Modified: 2011-09-26 17:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 17:55:13 UTC


Attachments (Terms of Use)

Description James Cape 2011-09-26 17:11:01 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-0.rc6.git0.3.fc16.x86_64
reason:         SELinux is preventing /bin/bash from 'getattr' accesses on the file /lib/systemd/system/iptables.service.
time:           Mon Sep 26 12:10:53 2011

description:
:SELinux is preventing /bin/bash from 'getattr' accesses on the file /lib/systemd/system/iptables.service.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that bash should be allowed getattr access on the iptables.service file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep service /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:firewallgui_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:systemd_unit_file_t:s0
:Target Objects                /lib/systemd/system/iptables.service [ file ]
:Source                        service
:Source Path                   /bin/bash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           bash-4.2.10-4.fc16
:Target RPM Packages           iptables-1.4.12-2.fc16
:Policy RPM                    selinux-policy-3.10.0-32.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux orwell.ignore-your.tv
:                              3.1.0-0.rc6.git0.3.fc16.x86_64 #1 SMP Fri Sep 16
:                              12:26:22 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 26 Sep 2011 12:09:41 PM CDT
:Last Seen                     Mon 26 Sep 2011 12:09:41 PM CDT
:Local ID                      e4f121e9-4e73-4b60-9383-6fad7eba6420
:
:Raw Audit Messages
:type=AVC msg=audit(1317056981.880:192): avc:  denied  { getattr } for  pid=6510 comm="service" path="/lib/systemd/system/iptables.service" dev=dm-2 ino=54090 scontext=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_unit_file_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1317056981.880:192): arch=x86_64 syscall=stat success=yes exit=0 a0=1c9d800 a1=7fffb616bb00 a2=7fffb616bb00 a3=8 items=0 ppid=6509 pid=6510 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=service exe=/bin/bash subj=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 key=(null)
:
:Hash: service,firewallgui_t,systemd_unit_file_t,file,getattr
:
:audit2allow
:
:#============= firewallgui_t ==============
:allow firewallgui_t systemd_unit_file_t:file getattr;
:
:audit2allow -R
:
:#============= firewallgui_t ==============
:allow firewallgui_t systemd_unit_file_t:file getattr;
:

Comment 1 Daniel Walsh 2011-09-26 17:55:13 UTC

*** This bug has been marked as a duplicate of bug 741368 ***


Note You need to log in before you can comment on or make changes to this bug.