Bug 74143 - xvidtune FPE coredump
xvidtune FPE coredump
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
: 76608 (view as bug list)
Depends On:
Blocks: 82776 FC3Target
  Show dependency treegraph
 
Reported: 2002-09-16 17:39 EDT by Aleksey Nogin
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 13:34:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-09-16 17:39:21 EDT
In 7.3.94 ((null)) fresh install + full up2date I get xvidtune crash (before
popping up any X windows):

(gdb) run
Starting program: /usr/X11R6/bin/xvidtune
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
Vendor: Monitor Vendor, Model: Dell P1130
Num hsync: 1, Num vsync: 1
hsync range 0:  30.00 - 130.00
vsync range 0:  48.00 - 170.00
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
Program received signal SIGFPE, Arithmetic exception.
0x0804a03b in UpdateSyncRates ()
(gdb) bt
#0  0x0804a03b in UpdateSyncRates ()
#1  0x08049956 in GetModeLine ()
#2  0x0804c943 in main ()
#3  0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

At the same time /var/log/XFree86.0.log gets:

GetModeLine - scrn: 0 clock: 108000
GetModeLine - hdsp: 1400 hbeg: 0 hend: 0 httl: 0
              vdsp: 1050 vbeg: 0 vend: 0 vttl: 0 flags: 0
Comment 1 Mike A. Harris 2002-10-06 01:09:05 EDT
What video card do you have?  Also, could you please attach your
config file and X log file.

It appears DDC probe is being done, but perhaps the monitor is
returning invalid data, or data unexpected by the app.

I'll look into it once I've got your info.  Thanks.
Comment 2 Mike A. Harris 2002-12-14 11:55:51 EST
ping
Comment 3 Aleksey Nogin 2002-12-14 16:02:35 EST
Ah, sorry, completely forgot about needing to respond to this.

Video card: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
(see bug 79141 attachment 87648 [details] for lspci -vv output).

X config: see bug 79141 attachment 87647 [details]

X log: see bug 79141 attachment 87645 [details] for a log showing the X startup using this
exact configuration. Please let me know if you need a complete log, with the
stuff that xvidtune would cause to appear in there.

P.S. I do not really know how this works, but my interpretation of the events is
that the radeon driver leaves it to something external (BIOS, video card, etc)
to figure out what's the right vsync/hsync rates to drive the LCD, so xvidtune
gets all zeros and crashes when trying to divide something by it.

P.P.S. The problem is still there with XFree86-4.2.1-9
Comment 5 Mike A. Harris 2004-08-30 19:23:55 EDT
*** Bug 76608 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2004-09-24 13:34:30 EDT
We believe this issue to be resolved in our currently shipping
OS releases.  Please upgrade to Fedora Core 2 or later, and if this
issue turns out to still be reproduceable, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.
Comment 8 Aleksey Nogin 2004-09-24 14:26:53 EDT
Confirming, I can no longer reproduce this in FC2 + all updates.

Note You need to log in before you can comment on or make changes to this bug.