Bug 76608 - xvidtune crashes on start
xvidtune crashes on start
Status: CLOSED DUPLICATE of bug 74143
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 22:23 EDT by Burt Holzman
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xf86 config file (3.08 KB, text/plain)
2002-10-23 22:24 EDT, Burt Holzman
no flags Details
XFree86.0.log, as requested (54.63 KB, text/plain)
2002-10-31 00:12 EST, Burt Holzman
no flags Details
XF86Config on IBM T30 thinkpad (3.20 KB, application/octet-stream)
2002-12-13 17:26 EST, Pam Huntley
no flags Details
XFree86 log for IBM ThinkPad T30 laptop (29.28 KB, text/plain)
2002-12-13 17:27 EST, Pam Huntley
no flags Details
XF86Config for IBM ThinkPad X24 (ATI Technologies Inc Radeon Mobility M6 LY) (3.25 KB, text/plain)
2002-12-13 17:29 EST, Pam Huntley
no flags Details
XFree86 log for IBM ThinkPad X24 (29.72 KB, text/plain)
2002-12-13 17:30 EST, Pam Huntley
no flags Details

  None (edit)
Description Burt Holzman 2002-10-23 22:23:45 EDT
xvidtune crashes on start:

(gdb) run
Starting program: /usr/X11R6/bin/xvidtune 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
Vendor: Monitor Vendor, Model: ADI MicroScan 5V
Num hsync: 1, Num vsync: 1
hsync range 0:  30.00 -  64.00
vsync range 0:  50.00 - 100.00
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGFPE, Arithmetic exception.
0x0804a03b in UpdateSyncRates ()
(gdb) bt
#0  0x0804a03b in UpdateSyncRates ()
#1  0x08049956 in GetModeLine ()
#2  0x0804c943 in main ()
#3  0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6

--

This is with RH 8.0 vanilla (no patches yet).

/etc/X11/XF86Config included as attachment.
Comment 1 Burt Holzman 2002-10-23 22:24:16 EDT
Created attachment 81848 [details]
xf86 config file
Comment 2 Mike A. Harris 2002-10-25 23:43:45 EDT
xvidtune shouldn't ever segv, so there must be a bug in it.

However, your video card is not an officially supported piece of
hardware.  Our configuration tools select the "vesa" driver for
all unsupported hardware, in hopes that the video card BIOS isn't
buggy, and will provide working unaccelerated 2D video support.

I've just tried xvidtune on a few 8.0 machines here with native
drivers and it works.  I'll try it out again with the "vesa" driver
to see if I can reproduce it with any other hardware too.

Since it only seems to occur on unsupported hardware though, it's
a low priority problem.  I will however have a debugging session
to try and find the cause if I can reproduce it on any local
hardware.

One thing that might help me troubleshoot, is if you can attach
also your XFree86 server log from the server you're having the
xvidtune SEGV in.  The details in the log may be helpful in
determining what values are causing the FPE.  Likely a divide by
zero error somewhere.
Comment 3 Burt Holzman 2002-10-31 00:12:04 EST
Created attachment 82806 [details]
XFree86.0.log, as requested
Comment 4 Burt Holzman 2002-10-31 00:13:17 EST
One other fact -- this just seems to occur with the vesa driver.  If I use
NVidia's binary (closed source, etc etc) driver, xvidtune runs just fine.
Comment 5 Pam Huntley 2002-12-13 17:25:09 EST
Hi,  I see this bug also, on two separate ThinkPads, both with ATI drivers.  It
only occurs when I run xvidtune with no options, xvidtune -next actually works.  

I'll attach the logs and config files.
Comment 6 Pam Huntley 2002-12-13 17:26:13 EST
Created attachment 88706 [details]
XF86Config on IBM T30 thinkpad
Comment 7 Pam Huntley 2002-12-13 17:27:12 EST
Created attachment 88707 [details]
XFree86 log for IBM ThinkPad T30 laptop
Comment 8 Pam Huntley 2002-12-13 17:29:46 EST
Created attachment 88708 [details]
XF86Config for IBM ThinkPad X24 (ATI Technologies Inc Radeon Mobility M6 LY)
Comment 9 Pam Huntley 2002-12-13 17:30:22 EST
Created attachment 88709 [details]
XFree86 log for IBM ThinkPad X24
Comment 10 Mike A. Harris 2003-01-26 04:25:09 EST
I'll have to doublecheck to be sure, but I believe the vesa driver only
permits usage of predefined video modes.  I don't think you can resize
or move the screen around.  I'll need to investigate that though.

The video card is supported in rawhide XFree86 though, and will be in our
next release of Red Hat Linux as well.
Comment 11 Mike A. Harris 2004-08-30 19:23:51 EDT

*** This bug has been marked as a duplicate of 74143 ***
Comment 12 Red Hat Bugzilla 2006-02-21 13:50:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.