Bug 741509 - 100% translated should imply the translation is fully completed, not round up from 99.5%
Summary: 100% translated should imply the translation is fully completed, not round up...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 1.4-RC
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: zanata-dev-internal
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Keywords:
: 741154 (view as bug list)
Depends On:
Blocks: Zanata-1.4.1
TreeView+ depends on / blocked
 
Reported: 2011-09-27 05:52 UTC by Ding-Yi Chen
Modified: 2013-10-28 07:48 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-10-06 02:49:36 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 741523 None None None Never
Red Hat Bugzilla 1002489 None None None Never

Internal Trackers: 741523 1002489

Description Ding-Yi Chen 2011-09-27 05:52:05 UTC
Description of problem:
Say, if a project have 1000 words, if 995 words are translated, the project is showing as 100% completed.

This gives translators false impression that the project is completed, but there is work yet to be done. 

Version-Release number of selected component (if applicable):
Zanata version 1.4-alpha-2-SNAPSHOT (20110926-1021)

How reproducible:
Always

Steps to Reproduce:
1. We use project AboutFedora F11, Chinese simplified.
2. Translated most of the string (with the help of copyFromSource) and save as approved, except document About_Fedora-> Fedora Documentation
3. Visit the project page of About Fedora, reload the page.
  
Actual results:
Project shows Chinese simplified is 100% translated.

Expected results:
As 2 words (1 message) is still not translated, the % completed should not be 100%.

Additional info:

Comment 2 Ding-Yi Chen 2011-09-27 07:44:27 UTC
See also Bug 741523

Comment 3 Ding-Yi Chen 2011-09-28 02:23:58 UTC
*** Bug 741154 has been marked as a duplicate of this bug. ***

Comment 4 Alex Eng 2011-09-29 01:59:48 UTC
Bug fixed along with https://bugzilla.redhat.com/show_bug.cgi?id=741523.

Comment 6 Ding-Yi Chen 2011-10-04 00:52:57 UTC
VERIFIED with Zanata version 1.4.1-SNAPSHOT (20111003-1737)


Note You need to log in before you can comment on or make changes to this bug.