Bug 74195 - errors on font upgrade from 7.3 to 8
errors on font upgrade from 7.3 to 8
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-17 12:56 EDT by Chris Ricker
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-19 10:32:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-09-17 12:56:17 EDT
Upgrading from 7.3 to 8, I get the following in upgrade.log:

Upgrading XFree86-4.2.0-72.
Can't scan directory "/usr/share/fonts/default/TrueType"

I'm not sure why -- nothing looks wrong with that directory:

[kaboom@hanuman export]$ ls -l /usr/share/fonts/default/
total 16
-rw-r--r--    1 root     root           60 Sep 14 19:38 fonts.cache-1
drwxr-xr-x    2 root     root         4096 Sep 14 19:49 ghostscript
drwxr-xr-x    2 root     root         4096 Sep 15 00:10 TrueType
drwxr-xr-x    2 root     root         4096 Sep 15 00:10 Type1
[kaboom@hanuman export]$ ls -l /usr/share/fonts/default/TrueType/
total 1260
-rw-r--r--    1 root     root        57136 Feb 26  2002 arib____.ttf
-rw-r--r--    1 root     root        59740 Feb 26  2002 arir____.ttf
-rw-r--r--    1 root     root        75620 Feb 26  2002 chvor___.ttf
-rw-r--r--    1 root     root        69756 Feb 26  2002 chvr____.ttf
-rw-r--r--    1 root     root        65944 Feb 26  2002 cogb____.ttf
-rw-r--r--    1 root     root        64292 Feb 26  2002 cogr____.ttf
-rw-r--r--    1 root     root         6466 Sep 14 19:38 fonts.cache-1
-rw-r--r--    1 root     root         1478 Sep 15 00:10 fonts.dir
-rw-r--r--    1 root     root         1478 Sep 15 00:10 fonts.scale
-rw-r--r--    1 root     root        54716 Feb 26  2002 helbi___.ttf
-rw-r--r--    1 root     root        51648 Feb 26  2002 helb____.ttf
-rw-r--r--    1 root     root        50660 Feb 26  2002 helcbi__.ttf
-rw-r--r--    1 root     root        46716 Feb 26  2002 helcb___.ttf
-rw-r--r--    1 root     root        50928 Feb 26  2002 helci___.ttf
-rw-r--r--    1 root     root        47780 Feb 26  2002 helcr___.ttf
-rw-r--r--    1 root     root        56168 Feb 26  2002 heli____.ttf
-rw-r--r--    1 root     root        52724 Feb 26  2002 helr____.ttf
-rw-r--r--    1 root     root        54896 Feb 26  2002 starbats.ttf
-rw-r--r--    1 root     root        53816 Feb 26  2002 starmath.ttf
-rw-r--r--    1 root     root        60116 Feb 26  2002 timbi___.ttf
-rw-r--r--    1 root     root        58624 Feb 26  2002 timb____.ttf
-rw-r--r--    1 root     root        61088 Feb 26  2002 timi____.ttf
-rw-r--r--    1 root     root        61816 Feb 26  2002 timr____.ttf
-rw-r--r--    1 root     root         3803 May  9 20:42 XftCache
[kaboom@hanuman export]$ rpm -qf /usr/share/fonts/default/TrueType/arib____.ttf 
ttfonts-1.0-9
[kaboom@hanuman export]$
Comment 1 Mike McLean 2002-12-13 16:59:28 EST
fwiw, still seeing this with XFree86-4.2.99.2-0.20021210.0
Comment 2 Mike A. Harris 2002-12-14 11:53:32 EST
I believe this is a bug in the ttfonts package.  That package is obsolete now
however.  It's not my package, but I get enough bug reports about it that I'm
thinking of taking it over and releasing erratum so that users who have
upgraded to all erratum released, at least don't see issues like this.
Comment 3 Mike A. Harris 2003-01-15 08:37:30 EST
*** Bug 78708 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2003-01-15 08:43:36 EST
This is a very low priority issue.  Whoever marked it "high" severity
has a good sense of humor though.  ;o)

Defering for future, as QA has better things to do right now than test
trivial updates like this one currently.  I'll reopen this when workload
is lighter and time can be justified doing it.
Comment 7 Mike A. Harris 2003-11-19 10:32:56 EST
bug 78708 which was marked as a dupe of this, on rereading, does
not seem to be a dupe, so I've marked it as a dupe of bug 71146,
the master dupe of the ttfonts xftcache bug.

The ttfonts package is no longer in the distribution anymore, and
the package maintainer has indicated that there will not be any
future erratum for the package, so if this problem is packaging
or installation related, it probably wont ever be fixed at this
point.

The only other possible cause that comes to mind, could perhaps
be the xfs initscript but I doubt that.  Nonetheless, the xfs
initscript in Fedora Core 1, and the latest XFree86 4.3.0-2.90.43
erratum for Red Hat Linux 9, contain a mostly rewritten xfs
initscript which should solve all known problems with the initscript
font processing in addition to giving a rather speedy performance
boost during system bootup.

I'm closing this issue as WONTFIX for the time being, however
if the issue is still relevant in Fedora Core 1, and you believe
it is either xfs initscript related, font metadata processing
utility related, or font packaging/installation related, feel free
to reopen the report with your thoughts, and we'll try to
investigate the issue on a current OS installation.

Note You need to log in before you can comment on or make changes to this bug.