Bug 741992 - qemu-kvm should require seabios-bin >= 0.6.2
qemu-kvm should require seabios-bin >= 0.6.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 735082 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-28 13:55 EDT by Eric Blake
Modified: 2013-01-09 06:55 EST (History)
13 users (show)

See Also:
Fixed In Version: qemu-0.15.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-04 21:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2011-09-28 13:55:48 EDT
Description of problem:
The virt-preview repo is built by backporting the F16 qemu srpm to F15.  But since qemu advertised boot reordering, without explicitly requiring a version of seabios-bin that provides boot reordering, this means that a naive use of virt-preview in F15 results in a broken boot.  By fixing the F16 spec file, the F15 virt-preview use will be fixed.

Version-Release number of selected component (if applicable):
qemu-system-x86-0.15.0-4.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum deplist qemu-system-x86, look for seabios-bin line
2.
3.
  
Actual results:
  dependency: seabios-bin
   provider: seabios-bin.noarch 0.6.2-2.fc16
Note that no explicit version was listed, which means we could downgrade seabios-bin below 0.6.2 and break boot reordering.

Expected results:
  dependency: seabios-bin >= 0.6.2
This will make the bios match qemu's advertisement, and allow virt-preview on F15 to work.

Additional info:
https://www.redhat.com/archives/libvir-list/2011-September/msg01171.html
Comment 1 Justin M. Forbes 2011-10-21 13:35:37 EDT
*** Bug 735082 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2011-10-21 16:56:05 EDT
qemu-0.15.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qemu-0.15.1-1.fc16
Comment 3 Fedora Update System 2011-10-21 20:10:06 EDT
Package qemu-0.15.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-0.15.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-14698
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-11-04 21:23:10 EDT
qemu-0.15.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.