Bug 742032 - [abrt] kernel: WARNING: at arch/x86/xen/mmu.c:475 xen_make_pte+0x32/0x8e(): TAINTED ---------W
[abrt] kernel: WARNING: at arch/x86/xen/mmu.c:475 xen_make_pte+0x32/0x8e(): T...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:1df95ad1faa006524cc8fbf050f...
:
: 745574 765604 787403 802532 (view as bug list)
Depends On:
Blocks: 741684
  Show dependency treegraph
 
Reported: 2011-09-28 16:07 EDT by Jerry Amundson
Modified: 2012-07-17 08:40 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 08:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pvops: make pte_flags() go via pvops (1.58 KB, patch)
2011-10-24 21:20 EDT, Konrad Rzeszutek Wilk
no flags Details | Diff
Use pte_val instead of pte_flags to retrieve the page flags when changing caching. (6.19 KB, patch)
2011-11-07 16:18 EST, Konrad Rzeszutek Wilk
no flags Details | Diff

  None (edit)
Description Jerry Amundson 2011-09-28 16:07:52 EDT
libreport version: 2.0.5.982
abrt_version:   2.0.4.981
cmdline:        placeholder root=/dev/mapper/vg_jerryopti755-lv_root ro quiet rhgb
comment:        Seems to occur when returning from the X screensaver (KDE picture slideshow), and only when booted into the Xen hypervisor.
event_log:      2011-09-28-15:07:33> Smolt profile successfully saved
kernel:         undefined
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
reason:         WARNING: at arch/x86/xen/mmu.c:475 xen_make_pte+0x32/0x8e()
time:           Tue Sep 27 14:05:22 2011

backtrace:
:WARNING: at arch/x86/xen/mmu.c:475 xen_make_pte+0x32/0x8e()
:Hardware name: OptiPlex 755                 
:Modules linked in: nfs fscache auth_rpcgss nfs_acl tcp_lp ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ip6table_filter nf_conntrack ip6_tables snd_hda_codec_analog xen_netback xen_blkback xen_gntdev xen_evtchn snd_hda_intel snd_hda_codec usblp i2c_i801 xenfs serio_raw dcdbas 3c59x mii snd_hwdep uinput iTCO_wdt iTCO_vendor_support snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc sunrpc e1000e pata_acpi usb_storage ata_generic radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 918, comm: X Tainted: G        W   3.1.0-0.rc6.git0.3.fc16.x86_64 #1
:Call Trace:
: [<ffffffff81057b32>] warn_slowpath_common+0x83/0x9b
: [<ffffffff81057b64>] warn_slowpath_null+0x1a/0x1c
: [<ffffffff8100527e>] xen_make_pte+0x32/0x8e
: [<ffffffff810045f1>] __raw_callee_save_xen_make_pte+0x11/0x1e
: [<ffffffff81032b0a>] ? pfn_pte+0x26/0x29
: [<ffffffff81032f75>] __change_page_attr_set_clr+0x130/0x749
: [<ffffffff8100782a>] ? get_phys_to_machine+0x1f/0x62
: [<ffffffff81005318>] ? mfn_to_pfn.part.3+0x3e/0x88
: [<ffffffff8100539d>] ? pte_mfn_to_pfn+0x3b/0x4d
: [<ffffffff81005c03>] ? __xen_set_pte+0x1b/0x5b
: [<ffffffff81033543>] __change_page_attr_set_clr+0x6fe/0x749
: [<ffffffff811064e7>] ? __purge_vmap_area_lazy+0x7c/0x17d
: [<ffffffff810336da>] change_page_attr_set_clr+0x14c/0x305
: [<ffffffff81033aa7>] _set_pages_array+0xa3/0xf1
: [<ffffffff81033b08>] set_pages_array_wc+0x13/0x15
: [<ffffffffa0065a21>] ttm_set_pages_caching+0x39/0x5b [ttm]
: [<ffffffffa0065b16>] ttm_alloc_new_pages+0xd3/0x15b [ttm]
: [<ffffffffa0065dfd>] ttm_get_pages+0x137/0x361 [ttm]
: [<ffffffffa005fdba>] __ttm_tt_get_page+0x54/0xb0 [ttm]
: [<ffffffffa0060099>] ttm_tt_populate+0x3d/0x7c [ttm]
: [<ffffffffa006010a>] ttm_tt_bind+0x32/0x66 [ttm]
: [<ffffffffa006177e>] ttm_bo_handle_move_mem+0x108/0x295 [ttm]
: [<ffffffffa0061baa>] ttm_bo_evict+0x29f/0x2e8 [ttm]
: [<ffffffffa0061d45>] ttm_mem_evict_first+0x152/0x180 [ttm]
: [<ffffffffa00623ba>] ttm_bo_mem_space+0x29b/0x2ea [ttm]
: [<ffffffffa00624bf>] ttm_bo_move_buffer+0xb6/0x10c [ttm]
: [<ffffffffa001ec90>] ? drm_mm_insert_helper+0xd3/0xec [drm]
: [<ffffffffa00625cb>] ttm_bo_validate+0xb6/0xf4 [ttm]
: [<ffffffffa0062909>] ttm_bo_init+0x300/0x339 [ttm]
: [<ffffffffa009a442>] radeon_bo_create+0x1bf/0x248 [radeon]
: [<ffffffffa009a194>] ? radeon_bo_clear_surface_reg+0x50/0x50 [radeon]
: [<ffffffffa00a9f4a>] radeon_gem_object_create+0x53/0xd8 [radeon]
: [<ffffffffa00aa202>] radeon_gem_create_ioctl+0x4b/0x81 [radeon]
: [<ffffffff8104402b>] ? should_resched+0xe/0x2d
: [<ffffffffa0015784>] drm_ioctl+0x29e/0x37b [drm]
: [<ffffffffa00aa1b7>] ? radeon_gem_pwrite_ioctl+0x28/0x28 [radeon]
: [<ffffffff811ded34>] ? inode_has_perm+0x32/0x34
: [<ffffffff811deddd>] ? file_has_perm+0xa7/0xc9
: [<ffffffff8113748f>] do_vfs_ioctl+0x452/0x493
: [<ffffffff81137526>] sys_ioctl+0x56/0x7c
: [<ffffffff814bbfc2>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 714ae92a-a2d2-4bb7-b58e-e5dae938ae66
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5985.14
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
:CPU Stepping: 6
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2992
:System Memory: 1452
:System Swap: 3967
:Vendor: Dell Inc.
:System: OptiPlex 755 
:Form factor: Mini Tower
:Kernel: 3.1.0-0.rc6.git0.3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10558:4136:529) pci, snd_hda_intel, MULTIMEDIA, Optiplex 755
:(32902:10550:4136:529) pci, uhci_hcd, USB, Optiplex 755
:(32902:10544:4136:529) pci, i801_smbus, SERIAL, Optiplex 755
:(32902:10530:4136:529) pci, ahci, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller
:(32902:10560:4136:529) pci, pcieport, PCI/PCI, Optiplex 755
:(32902:10516:0:0) pci, None, PCI/ISA, 82801IO (ICH9DO) LPC Interface Controller
:(4098:38081:4136:3330) pci, radeon, VIDEO, Optiplex 755
:(32902:10676:4136:529) pci, None, SIMPLE, OptiPlex 755
:(32902:10679:4136:529) pci, serial, 16550_SERIAL, OptiPlex 755
:(32902:10678:4136:529) pci, ata_generic, STORAGE, OptiPlex 755
:(32902:4285:4136:529) pci, e1000e, ETHERNET, OptiPlex 755
:(32902:10549:4136:529) pci, uhci_hcd, USB, Optiplex 755
:(4279:37376:4279:4096) pci, 3c59x, ETHERNET, 3C905CX-TX/TX-M Fast Etherlink for PC Management NIC
:(32902:9294:4136:529) pci, None, PCI/PCI, Optiplex 755
:(32902:10548:4136:529) pci, uhci_hcd, USB, Optiplex 755
:(32902:10551:4136:529) pci, uhci_hcd, USB, Optiplex 755
:(32902:10552:4136:529) pci, uhci_hcd, USB, Optiplex 755
:(32902:10672:4136:529) pci, None, HOST/PCI, OptiPlex 755
:(32902:10556:4136:529) pci, ehci_hcd, USB, Optiplex 755
:(32902:10554:4136:529) pci, ehci_hcd, USB, Optiplex 755
:(32902:10673:4136:529) pci, pcieport, PCI/PCI, OptiPlex 755
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_jerryopti755-lv_root / ext4 4096 4096 12901535 8190444 7535084 3276800 2692220 2692220
:/dev/sda1 /boot ext4 1024 1024 495844 426074 400474 128016 127741 127741
:/dev/mapper/vg_jerryopti755-lv_home /home ext4 4096 4096 24416173 3008589 1768321 6201344 6176779 6176779
:
Comment 1 Konrad Rzeszutek Wilk 2011-09-29 17:16:49 EDT
Can you pass 'nopat' on the Linux command line and see if that makes the warning  go away?

What is the ATI/AMD card you have in your machine?
Comment 2 Jerry Amundson 2011-09-29 23:26:53 EDT
(In reply to comment #1)
> Can you pass 'nopat' on the Linux command line and see if that makes the
> warning  go away?

OK, will do when I have access to it on Tuesday.

> What is the ATI/AMD card you have in your machine?

OTTOMH, I think it's an RV610.
Comment 3 Jon S 2011-10-08 08:13:45 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Sorry, I'm just responding to the ABRT alert and reporting the bug cos I'm nice.

abrt reported a xen kernel crash. system is still running OK though (not currently running any VMs though).

I was just browsing the net at the time, only Firefox running
Comment 4 Jerry Amundson 2011-10-10 15:37:21 EDT
(In reply to comment #1)
> Can you pass 'nopat' on the Linux command line and see if that makes the
> warning  go away?

I've confirmed that it does.

> What is the ATI/AMD card you have in your machine?

RV610:
[    23.850] (--) RADEON(0): Chipset: "ATI Radeon HD 2400 XT" (ChipID = 0x94c1)
Comment 5 Josh Boyer 2011-10-24 16:03:04 EDT
(In reply to comment #1)
> Can you pass 'nopat' on the Linux command line and see if that makes the
> warning  go away?

Konrad, as Jerry reported 'nopat' makes this go away.  Do you know if there is an upstream change pending in this area or have any further ideas?
Comment 6 Konrad Rzeszutek Wilk 2011-10-24 21:20:59 EDT
Created attachment 529979 [details]
pvops: make pte_flags() go via pvops

Hey Josh,

There is this patch that will make the warning (and the problem as far as I can remember) go away. But ... I *think* I tested it when I saw this with my Radeon box and while the warnings did go away I saw ext4 and userspace programs dying with weird errors. The reason for all of this is that pages are being returned by TTM to the main memory management which then eventually tries to recycle them (and coalesce collections of them in 2MB pages). Anyhow, some of those pages end up being used by applications, other kernel subsystems, etc.. except that some of them seem to have Write Combined flags set! Which is really bad for some applications.

It also could be that when I compiled a kernel with this patch I had booted the wrong kernel and in effect never tested the patch :-(

So what I am saying is - yes there is a patch, but I am not yet sure if this the right cure for the problem. Need to investigate this more.
Comment 7 Konrad Rzeszutek Wilk 2011-11-07 16:18:20 EST
Created attachment 532138 [details]
Use pte_val instead of pte_flags to retrieve the page flags when changing caching.

The previous patch did make it work, but it is such a big hammer that I am not comfortable with it. The patch attached here solves the problem for me. I would appreciate if somebody tested it besides me just to make sure it works.

Note, the patch has not yet been posted on LKML, but will shortly.
Comment 8 Josh Boyer 2011-11-09 13:25:50 EST
This seems like 2/3 in this series:

http://thread.gmane.org/gmane.comp.emulators.xen.devel/115063/focus=1212837

which is (hopefully?) going to get queued up for -stable.
Comment 9 Raphos 2011-12-08 17:28:49 EST
Package: kernel
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Install xen
Comment 10 Chuck Ebbert 2011-12-08 20:01:59 EST
*** Bug 765604 has been marked as a duplicate of this bug. ***
Comment 11 Josh Boyer 2012-02-28 17:11:10 EST
A temporary fix went into 3.3 with commit 8eaffa67b43e99ae581622c5133e20b0f48bcef1.

Konrad, is that going to be brought back to 3.2 stable?
Comment 12 Josh Boyer 2012-02-28 17:12:29 EST
*** Bug 787403 has been marked as a duplicate of this bug. ***
Comment 13 Dave Jones 2012-03-12 14:52:24 EDT
*** Bug 802532 has been marked as a duplicate of this bug. ***
Comment 14 Dave Jones 2012-03-22 13:06:32 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 15 Dave Jones 2012-03-22 13:09:45 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 16 Dave Jones 2012-03-22 13:20:05 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 17 Konrad Rzeszutek Wilk 2012-03-23 16:52:10 EDT
(In reply to comment #11)
> A temporary fix went into 3.3 with commit
> 8eaffa67b43e99ae581622c5133e20b0f48bcef1.
> 
> Konrad, is that going to be brought back to 3.2 stable?

I should do that. Let me email Greg so that he can queue them up. Thanks
Comment 18 Konrad Rzeszutek Wilk 2012-03-23 17:12:17 EDT
*** Bug 745574 has been marked as a duplicate of this bug. ***
Comment 19 Josh Boyer 2012-07-17 08:40:28 EDT
This was fixed in 3.3/3.4

Note You need to log in before you can comment on or make changes to this bug.