Bug 745574 - [crash] BUG: unable to handle kernel NULL pointer dereference at 0000000000000010 IP: [<ffffffff81081c3a>] atomic_inc+0x9/0xe
[crash] BUG: unable to handle kernel NULL pointer dereference at 000000000000...
Status: CLOSED DUPLICATE of bug 742032
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-12 14:27 EDT by Jerry Amundson
Modified: 2012-03-23 17:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 17:12:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2011-10-12 14:27:00 EDT
Description of problem:
BUG: unable to handle kernel NULL pointer dereference at 0000000000000010

Version-Release number of selected component (if applicable):
xen-4.1.1-6.fc16.x86_64

How reproducible:
many times

Steps to Reproduce:
1. cannot reliably reproduce
2. crashes X session 
3. I did not see it with the kernel on bare metal.
  
Actual results:
reboot

Expected results:
no crash

Additional info:

Oct 12 11:03:48 jerry-opti755 kernel: [73491.786021] BUG: unable to handle kernel NULL pointer dereference at 0000000000000010
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] IP: [<ffffffff81081c3a>] atomic_inc+0x9/0xe
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] PGD 567ae067 PUD 542c5067 PMD 0 
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] Oops: 0002 [#1] SMP 
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] CPU 0 
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] Modules linked in: tcp_lp nfs fscache auth_rpcgss nfs_acl ppdev parport_pc lp parport ebt
able_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc lockd drbd lru_cache ip6t_REJECT nf_conntrac
k_ipv4 nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_analog xen_netback xen_b
lkback xen_gntdev xen_evtchn snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm uinput sunrpc 3c59x mii snd_timer snd dcdbas
 soundcore snd_page_alloc serio_raw iTCO_wdt iTCO_vendor_support i2c_i801 e1000e xenfs pata_acpi usb_storage ata_generic radeon ttm drm_kms_he
lper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] 
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] Pid: 1565, comm: thunderbird-bin Tainted: G        W   3.1.0-0.rc9.git0.0.fc16.x86_64 #1 
Dell Inc. OptiPlex 755                 /0GM819
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] RIP: e030:[<ffffffff81081c3a>]  [<ffffffff81081c3a>] atomic_inc+0x9/0xe
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] RSP: e02b:ffff880042625d18  EFLAGS: 00010246
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] RAX: 0000000000000001 RBX: 0000000000000000 RCX: ffff880042625dc4
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] RDX: ffff8800041cec80 RSI: ffff880042625d88 RDI: 0000000000000010
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] RBP: ffff880042625d18 R08: 0000000046ba665d R09: ffff880042625ef8
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] R10: 000000007fffffff R11: 0000000000000283 R12: ffff88004db31ce0
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] R13: ffff88004db31ce0 R14: 0000000000000000 R15: 0000000000000000
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] FS:  00007f31ebf9d9c0(0000) GS:ffff880074038000(0000) knlGS:0000000000000000
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] CS:  e033 DS: 0000 ES: 0000 CR0: 000000008005003b
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] CR2: 0000000000000010 CR3: 0000000042895000 CR4: 0000000000002660
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] Process thunderbird-bin (pid: 1565, threadinfo ffff880042624000, task ffff880041955cc0)
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] Stack:
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  ffff880042625d38 ffffffff81081fc3 ffffffff81ce9d70 ffffffff81ce99f8
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  ffff880042625df8 ffffffff81083203 00000000ffffffff 0000000042625db0
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  ffffffff81ce9a00 000000017fffffff ffffffff81ce9d78 ffffffff81ce9d60
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] Call Trace:
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff81081fc3>] wake_futex+0x1c/0x47
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff81083203>] futex_requeue+0x3d2/0x537
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff81083f3e>] do_futex+0xf3/0x857
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff81007292>] ? check_events+0x12/0x20
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff81007292>] ? check_events+0x12/0x20
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff8100727f>] ? xen_restore_fl_direct_reloc+0x4/0x4
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff810847d6>] sys_futex+0x134/0x146
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff814b6986>] ? do_device_not_available+0xe/0x10
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  [<ffffffff814bc0c2>] system_call_fastpath+0x16/0x1b
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] Code: 36 e9 35 ff ff ff 48 83 c4 38 5b 41 5c 41 5d 41 5e 41 5f 5d c3 55 48 89 e5 ff 14 25
 18 6c a1 81 5d c3 55 48 89 e5 66 66 66 66 90 <f0> ff 07 5d c3 55 48 89 e5 66 66 66 66 90 f0 ff 0f 0f 94 c0 84 
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] RIP  [<ffffffff81081c3a>] atomic_inc+0x9/0xe
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986]  RSP <ffff880042625d18>
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] CR2: 0000000000000010
Oct 12 11:03:48 jerry-opti755 kernel: [73491.786986] ---[ end trace 87367056179db2a5 ]---
Comment 1 Jerry Amundson 2011-10-25 15:36:12 EDT
Any direction for me on this? I'm now running the latest and greatest..
kernel-3.1.0-1.fc16.x86_64
xen-4.1.1-8.fc16.x86_64

yet, still run into this crash after a few hours uptime. I do not have problems with the stand-alone kernel.
Comment 2 Michael Young 2011-10-25 15:57:06 EDT
The latest and greatest xen is actually xen-4.1.2-1 which you can get from
http://koji.fedoraproject.org/koji/buildinfo?buildID=269986 though it should reach updates-testing in the next day or so. This may help, though I think your problem is more likely to be at the kernel end.
Comment 3 Konrad Rzeszutek Wilk 2011-10-25 21:45:22 EDT
Jerry,

Was there anything before this crash? Were there any warnings? What is the type of video card you have? Can you provide the lspci?
Comment 4 Konrad Rzeszutek Wilk 2011-10-25 21:46:54 EDT
Oh, and one more thing, you do not get this warning:

Bug 742032 - [abrt] kernel: WARNING: at arch/x86/xen/mmu.c:475 xen_make_pte+0x32/0x8e(): TAINTED ---------W

right?
Comment 5 Jerry Amundson 2011-10-26 10:31:28 EDT
(In reply to comment #3)
> Jerry,
> 
> Was there anything before this crash? Were there any warnings? What is the type
> of video card you have? Can you provide the lspci?

No warnings. The situation can vary from opening a new application, to typing quickly on the keyboard.

00:00.0 Host bridge: Intel Corporation 82Q35 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82Q35 Express PCI Express Root Port (rev 02)
00:03.0 Communication controller: Intel Corporation 82Q35 Express MEI Controller (rev 02)
00:03.2 IDE interface: Intel Corporation 82Q35 Express PT IDER Controller (rev 02)
00:03.3 Serial controller: Intel Corporation 82Q35 Express Serial KT Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82566DM-2 Gigabit Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IO (ICH9DO) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV610 [Radeon HD 2400 XT]
03:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
Comment 6 Jerry Amundson 2011-10-26 10:44:10 EDT
(In reply to comment #4)
> Oh, and one more thing, you do not get this warning:
> 
> Bug 742032 - [abrt] kernel: WARNING: at arch/x86/xen/mmu.c:475
> xen_make_pte+0x32/0x8e(): TAINTED ---------W
> 
> right?

Correct. Per messages, it has not occurred since reboot...

Oct 25 13:49:50 jerry-opti755 kernel: [ 9615.575722] WARNING: at arch/x86/xen/mmu.c:475 xen_make_pte+0x32/0x8e()

Oct 25 14:19:03 jerry-opti755 kernel: [    0.000000] Kernel command line: placeholder root=/dev/mapper/vg_jerryopti755-lv_root ro quiet rhgb SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us earlyprintk=xen xencons=hvc0

Just updated, and will reboot now:
kernel-3.1.0-1.fc16.x86_64
xen-4.1.2-1.fc16.x86_64
Comment 7 Jerry Amundson 2011-10-26 11:50:28 EDT
Correction, I am seeing:

Bug 742032 - [abrt] kernel: WARNING: at arch/x86/xen/mmu.c:475
 xen_make_pte+0x32/0x8e(): TAINTED ---------W

I will reboot with "nopat".
Comment 8 Konrad Rzeszutek Wilk 2012-03-23 17:12:17 EDT

*** This bug has been marked as a duplicate of bug 742032 ***

Note You need to log in before you can comment on or make changes to this bug.