Bug 74211 - redhat-logviewer doesn't work
redhat-logviewer doesn't work
Status: CLOSED DUPLICATE of bug 71876
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-logviewer (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Depends On:
  Show dependency treegraph
Reported: 2002-09-17 17:54 EDT by Stiphane Lozada
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-09-17 21:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stiphane Lozada 2002-09-17 17:54:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
I tried to start System Logs from Gnome menu without success. Then I tried to
launch directly the binary /usr/bin/redhat-logviewer and I understood something
might be wrong, see below in additional info what I got on the terminal.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.try to start /usr/bin/redhat-logviewer

Additional info:

Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 30, in ?
    import LogViewerGui
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 123, in ?
    sysClass = LogFileClass.LogFileClass("SYSLOG")
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 69, in __init__
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 119, in read_log
    self.buffer.insert_into_buffer_at_offset(iter, line)
  File "/usr/share/redhat-logviewer/LogBuffer.py", line 57, in
    self.insert(iter, unicode(new_line,'utf-8'), -1)
UnicodeError: UTF-8 decoding error: unexpected code byte
Comment 1 Miloslav Trmac 2002-09-17 21:40:10 EDT
The same for me. One possible reason are the timestamps in log messages. They
are for some reason localized and get munged along the way, at least for
Comment 2 Tammy Fox 2002-09-18 17:05:35 EDT
This is fixed in the latest rawhide version. 

*** This bug has been marked as a duplicate of 71876 ***

Note You need to log in before you can comment on or make changes to this bug.