Bug 71876 - Crashes when trying to start.
Summary: Crashes when trying to start.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-logviewer   
(Show other bugs)
Version: null
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tammy Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 74211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-19 22:24 UTC by Mikael Hallendal
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-18 21:05:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.1.log (26.04 KB, patch)
2002-08-21 20:24 UTC, Mikael Hallendal
no flags Details | Diff
boot.log (13.83 KB, text/plain)
2002-08-21 20:25 UTC, Mikael Hallendal
no flags Details
cron (1.68 KB, text/plain)
2002-08-21 20:25 UTC, Mikael Hallendal
no flags Details
dmesg (7.65 KB, text/plain)
2002-08-21 20:26 UTC, Mikael Hallendal
no flags Details
So, I'm an idiot, here they all are package in a tar ball :) (24.14 KB, application/octet-stream)
2002-08-21 20:27 UTC, Mikael Hallendal
no flags Details

Description Mikael Hallendal 2002-08-19 22:24:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start the program.

	

Actual Results:  Crashes

Additional info:

[micke@fluffy micke]$ redhat-logviewer
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 30, in ?
    import LogViewerGui
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 123, in ?
    sysClass = LogFileClass.LogFileClass("SYSLOG")
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 69, in __init__
    self.read_log(self.prefName)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 119, in read_log
    self.buffer.insert_into_buffer_at_offset(iter, line)
  File "/usr[micke@fluffy micke]$ redhat-logviewer
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 30, in ?
    import LogViewerGui
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 123, in ?
    sysClass = LogFileClass.LogFileClass("SYSLOG")
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 69, in __init__
    self.read_log(self.prefName)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 119, in read_log
    self.buffer.insert_into_buffer_at_offset(iter, line)
  File "/usr/share/redhat-logviewer/LogBuffer.py", line 57, in
insert_into_buffer_at_offset
    self.insert(iter, unicode(new_line,'utf-8'), -1)
UnicodeError: UTF-8 decoding error: unexpected code byte
/share/redhat-logviewer/LogBuffer.py", line 57, in insert_into_buffer_at_offset
    self.insert(iter, unicode(new_line,'utf-8'), -1)
UnicodeError: UTF-8 decoding error: unexpected code byte

Comment 1 Tammy Fox 2002-08-19 22:48:19 UTC
Try version 0.8.2-1 from rawhide; it should work.

Comment 2 Tammy Fox 2002-08-19 22:58:05 UTC
I also put it here: http://people.redhat.com/tfox/

Comment 3 Tammy Fox 2002-08-20 16:02:18 UTC
Also, please attach your log files so QA can verify that it is fixed.

Comment 4 Mikael Hallendal 2002-08-20 18:24:26 UTC
I'll reboot into the beta and verify this later tonight.

Comment 5 Mikael Hallendal 2002-08-21 20:23:55 UTC
Sorry I didn't get around doing it last night. Did it now instead.
As you said, it works with 0.8.2. 

Attaching the log files below.

Comment 6 Mikael Hallendal 2002-08-21 20:24:41 UTC
Created attachment 72065 [details]
XFree86.1.log

Comment 7 Mikael Hallendal 2002-08-21 20:25:16 UTC
Created attachment 72067 [details]
boot.log

Comment 8 Mikael Hallendal 2002-08-21 20:25:42 UTC
Created attachment 72068 [details]
cron

Comment 9 Mikael Hallendal 2002-08-21 20:26:17 UTC
Created attachment 72069 [details]
dmesg

Comment 10 Mikael Hallendal 2002-08-21 20:27:37 UTC
Created attachment 72071 [details]
So, I'm an idiot, here they all are package in a tar ball :)

Comment 11 Mikael Hallendal 2002-08-21 20:50:34 UTC
ok, not only am I a complete idiot, I'm also a stupid idiot :)
The file should be named logs.tar.bz2 not logs.tar.gz

Sorry about this entire mess :/

Comment 12 Tammy Fox 2002-08-22 15:24:24 UTC
Great. I'm glad it worked for you.

Comment 13 Tammy Fox 2002-09-18 21:05:28 UTC
*** Bug 74211 has been marked as a duplicate of this bug. ***

Comment 14 Tammy Fox 2002-10-16 14:43:05 UTC
I'm closing this out since the fix was confirmed by the reporter.


Note You need to log in before you can comment on or make changes to this bug.