Bug 742426 - Navigation buttons are hidden if user returns to the project file list from the editor and opens a new file
Navigation buttons are hidden if user returns to the project file list from t...
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.4
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
: 766474 (view as bug list)
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-09-30 00:54 EDT by Runa Bhattacharjee
Modified: 2013-03-03 21:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-26 21:03:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Runa Bhattacharjee 2011-09-30 00:54:30 EDT
Description of problem:

When a user returns from the Translation Editor to the list of files in the project, and opens a file in the editor by clicking on a file from the list, the navigation buttons on the editor are initially hidden. When a translation unit is clicked, the navigation buttons are displayed again.


Version-Release number of selected component (if applicable):

1.4

How reproducible:


Steps to Reproduce:
1. After logging into Zanata with adequate permissions, click on 'Projects'
2. Select a project with multiple files
3. Click 'Translate' for a language of your choice
4. From the displayed list, select a file to translate and open it in the Editor
5. Return to the file list displayed in step #4 by clicking on the name of the project at the top left corner of the Editor's banner (displayed as 'projectname > filename')
6. Click on any file from the list and open it in the Editor

  
Actual results:

After step 6, the navigation buttons at the top centre of the Editing area is hidden. A click on a translation unit, brings them back.


Expected results:

After step 6, the navigation buttons should be displayed


Additional info:
Comment 1 Ding-Yi Chen 2011-10-11 22:58:31 EDT
This bug is reproduced with Firefox 3.6 but not Chrome and Firefox 7
Comment 2 Runa Bhattacharjee 2011-12-12 04:23:58 EST
*** Bug 766474 has been marked as a duplicate of this bug. ***
Comment 3 David Mason 2011-12-12 20:08:27 EST
Note that the editor table appears to be positioned over the navigation buttons, and the stats or search bar (depending on the Zanata UI version).

More specifically, opening an editor cell causes the buttons etc. to become visible again (a click that selects the TU but does not open an editor cell does not make them visible).
Comment 4 Alex Eng 2012-07-09 19:18:43 EDT
Runa, 

This bug is not reproducible now with Firefox 7 as standard browser. 
Can you please confirm the problem still exists with your current desktop environment?
Comment 5 Alex Eng 2012-08-26 21:03:10 EDT
Problem does not occur with Firefox 7 and beyond.

Note You need to log in before you can comment on or make changes to this bug.